Fatshark headtracker in Devo 8S?

More
19 Apr 2015 15:03 - 20 Apr 2015 11:13 #31360 by luenma
Fatshark headtracker in Devo 8S? was created by luenma
Hello,

I am trying to use the headtracker but it does not work, so I need help.

I have Fatshark Attitude and Devo 8S. You can see attached the connectors I have prepared and also the configuration in my Devo 8S. I try to use the channel 9 and 10 in my Devo 8S for Pan and Tilt. The headtracker is according to the factory default with Pan/tilt on CH 5/6 (I have tested the cable with one oscilloscope and it works). But I cannot see any movement in the channel 9 and 10 of my Devo 8S when I move the goggles.

I would like what I am doing wrong.

Thanks and regards.

Note: I have deleted the attachments in this message because as indicated in my message below they were wrong.
Last edit: 20 Apr 2015 11:13 by luenma.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 15:22 #31361 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
did you set "PPM In" to channel? and made the necessary configuration there?

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 16:47 - 19 Apr 2015 16:47 #31371 by luenma
Replied by luenma on topic Fatshark headtracker in Devo 8S?
I have done only the one you can see in the attached file "HeadtrackerDevo8S.pdf" in my previous message, but nothing more. I am not sure what do you mean with setting "PPM In" to channel and the configuration there...
Thanks and regards
Last edit: 19 Apr 2015 16:47 by luenma.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 16:54 #31372 by luenma
Replied by luenma on topic Fatshark headtracker in Devo 8S?
OK, I have just seen what you mean. You refer to the Model setup menu. I did not set "PPM In", you are right. I suppose I should set "PPM In" to "Channel" and then in my case all channels in "None" except PPM5 in Ch9 and PPM6 in Ch10, correct?
I suppose I should leave Trainer Sw with none and I am not sure about the adjustment for Center PW and Delta PW.
Thanks and regards

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 16:59 #31373 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
Go to the "model setup" page (next after the "mixer" page).
there you find PPM In. I guess it is set to NONE.
push > to set it to "channel"
then push on "channel" now you can make you configuration:
I think in your case it would be: PPM1 to PPM4 = None. PPM5 = Ch9. PPM6 = Ch10 .PPM7 and PPM8 = None.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 17:01 - 19 Apr 2015 17:03 #31374 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
Yes you are correct.
do not change Center PW or Delta PW, unless your fatshark use other numbers.
Last edit: 19 Apr 2015 17:03 by TomPeer.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 18:06 - 20 Apr 2015 11:14 #31376 by luenma
Replied by luenma on topic Fatshark headtracker in Devo 8S?
Still it does not work :(
I am using the set-up indicated in the attached document. But I cannot see anything in the channels 9 and 10 when I move my goggles. Again I have checked the cable with the oscilloscope and I see the channels 5 and 6 change when I move the goggles, so the problem is inside the transmitter or in the set-up. Or maybe in the procedure to turn on the transmitter before or after turn on the googles...
I have the connectors as the attached document, so GND and ppm as indicated in the photo. I suppose that is the correct way to do it...
Thanks and regards

Note: I have deleted the attachments in this message because as indicated in my message below they were wrong.
Last edit: 20 Apr 2015 11:14 by luenma.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:08 #31379 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
Do you get any reaction on the other channels?

P.S.
You tx power is set very low. If you are close to your model it does not matter. But if you go flying you have to set it higher.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:35 #31380 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
If you go to the channel monitor page, can you see any activity on channel 9 and 10 there?

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:37 #31381 by luenma
Replied by luenma on topic Fatshark headtracker in Devo 8S?
Yes, I get reaction on the other channels. The tx power is set to the minimum because I am testing at home, so it is not needed more power.
I check also the channels in the channel monitor and there is not any reaction in the channels 9 and 10.
I use PPM port in Phoenix and it works correctly, so I assume the hardware is ok. The other point is if the 3.5mm connector configuration I have indicated in the attachment is the correct one. And if the setting is also correct, then I do not have any idea about what is wrong :(

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:39 #31382 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
Are you sure the ppm and ground signal are not reversed?

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:42 - 19 Apr 2015 19:44 #31383 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
I am sorry to say i am out of ideas as well.
Maybe somebody else have an idea
Last edit: 19 Apr 2015 19:44 by TomPeer.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:44 - 20 Apr 2015 11:15 #31384 by luenma
Replied by luenma on topic Fatshark headtracker in Devo 8S?
I cannot say I am sure about that. I am sure the cable is according to the attached document. But I am not sure if that is the correct configuration.

Note: I have deleted the attachment in this message because as indicated in my message below it was wrong.
Last edit: 20 Apr 2015 11:15 by luenma.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 19:57 #31385 by TomPeer
Replied by TomPeer on topic Fatshark headtracker in Devo 8S?
I am not sure either. But i always thougt the ppm signal is on the centre pin of the jack plug.

Please Log in or Create an account to join the conversation.

More
19 Apr 2015 20:16 - 19 Apr 2015 20:20 #31386 by Wene001
Replied by Wene001 on topic Fatshark headtracker in Devo 8S?
Played around with "Channel" PPMin settings
Switch none doesnt work for me.
Try to set a switch (and switch it on :-) ) and assign PPM 5 to Ch9 and PPM 6 to Ch10
Then it should showe movement in Channel Monitor.
With this setup mixer for Ch9 and Ch10 is not used.

i would prefer to use "Extend" Setting for PPMin and use the mixer that you showed in the PDF above.

as shown here
www.deviationtx.com/forum/search?query=ppmin&childforums=1
i am using ppm signal on tip of the headphone jack, but i think deviation could handle both variants of signal
Last edit: 19 Apr 2015 20:20 by Wene001.

Please Log in or Create an account to join the conversation.

More
20 Apr 2015 09:37 - 20 Apr 2015 09:39 #31408 by linux-user
Replied by linux-user on topic Fatshark headtracker in Devo 8S?

luenma wrote: Still it does not work :(
I have the connectors as the attached document, so GND and ppm as indicated in the photo. I suppose that is the correct way to do it...

Attachment not found

Are you sure the polarity is right?
On the 3,5mm audio jack shouldn't there be signal at the middle pin and GND at the outside?
Last edit: 20 Apr 2015 09:39 by linux-user.

Please Log in or Create an account to join the conversation.

More
20 Apr 2015 11:08 #31409 by luenma
Replied by luenma on topic Fatshark headtracker in Devo 8S?
Finally it is solved :)

First, the polarity on the 3.5mm connector was not correct as you have indicated. I followed the polarity indicated in www.deviationtx.com/forum/model-configs/...tshark-head-tracking , but it seems it is not correct at least for my Devo 8S. The correct polarity in my case is ppm at the middle pin and GND at the outside as indicated in the new attachment.

Second, as indicated by Wene001 "PPM In" does not work in my case with "Channel", but with "Extend". So, finally my configuration is as indicated in the new attachment. I have also added the upper trims as you can see in the second page, so I can use the headtracker or/and the trims.

Thank you very much TomPeer, Weneoo1 and linux-user for your help!

File Attachment:

File Name: Fatsharkco...rev1.pdf
File Size:84 KB


File Attachment:

File Name: Headtracke...rev2.pdf
File Size:293 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Oct 2021 07:52 #77594 by jamiedg
Replied by jamiedg on topic Fatshark headtracker in Devo 8S?
Many thanks for all the info here.
Managed to use this to get my Fatshark Attitude v4 working with the Devo10.
Cable was exact same as stated. I used an old S-video cable that had the 4-pin din connector.
Mapped 5-6 to source ppm 5-6, was then able to see the movement being detected on the DevoTx channel monitor.
Great thing about the Attitude v4 is it has a built in tracker :)
One thing that caught me out at first was when you set the PPM input to Extend, press ENT to get the PPMcfg menu and check the Num of channels are set to 8.
Thanks again, J

Please Log in or Create an account to join the conversation.

Time to create page: 0.076 seconds
Powered by Kunena Forum