Devo 10 Deviation v5.0.0 GUI on RC size

More
01 Jul 2020 09:39 #76547 by Wilcox
Good day everyone.
I have a Devo 10 and have v4.0.1 firmware on the Controller and it works fine.
I used the DFuse tool on Windows 10 to upload Deviation v5.0.0 and once complete and disconnected from the computer, when I turn the Devo 10 on the GUI screen seems out of scale. I cannot see the menu when I open it and all the lines of text on the main screen are bunched up. Its like the GUI is using the wrong scale to display the pages.

I tried to look through the various .INI files to see if there was an issue but I dont know where to begin to resolve this.
I reinstalled V4.0.1 and it works just fine and the GUI is back to normal.
Does anyone perhaps have a solution?

Please Log in or Create an account to join the conversation.

More
01 Jul 2020 13:09 - 01 Jul 2020 13:11 #76552 by vlad_vy
Replied by vlad_vy on topic Devo 10 Deviation v5.0.0 GUI on RC size
You need renew transmitter filesystem also. Backup used model files, erase old filesystem, write new filesystem from firmware archive, setup and calibrate transmitter, return model files. Use Safely Remove Hardware after any write to transmitter filesystem.
Last edit: 01 Jul 2020 13:11 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
01 Jul 2020 14:13 #76553 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
Thank you.
So I Deleted all the old files after backing up my models.
I used DFUSe and updated Firmaware to 5.0.0. Ejected hardware.
Copied the files(Language, Modelico,Model etc) to the Devo transmitter)
Turned on the Devo again after ejecting and the LCD screen still does the same thing.
The Deviation splash screen looks too big. the menu page when selected only shows the word menu and no other options.

I reinstalled v4.0.0.1 and it goes back to working

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 05:25 #76554 by vlad_vy
Replied by vlad_vy on topic Devo 10 Deviation v5.0.0 GUI on RC size
I'm not sure, you copy to transmitter USB drive new filesystem (files) from firmware archive or from your old backup? From old backup you need return used model files only.

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 05:56 #76555 by Gerry
Replied by Gerry on topic Devo 10 Deviation v5.0.0 GUI on RC size
Which Dfuse? v2.31?
only thing i do that vlad_vy hasn't already said is I tend to do a format before copy new file system

Devo 7e A7105 NRF24L01 CC2500 2x3 way & voice, Devo 12e 4 in 1 & voice.
FFS (Forever Fixing Stuff)

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 07:08 #76556 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
After updating the V 5.0.0 Firmware and ejecting, I connect in USB mode. I copy the files from the Unzipped V5.0.0 folder ( except for the models folder that is from my backup)

I am using DFuse 2.31.
I will try a format as Gerry suggests. I read another post about an LCD init issue. Could it be related to that?

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 07:11 #76557 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
After updating the V 5.0.0 Firmware and ejecting, I connect in USB mode. I copy the files from the Unzipped V5.0.0 folder ( except for the models folder that is from my backup)

I am using DFuse 2.31.
I will try a format as Gerry suggests. I read another post about an LCD init issue. Could it be related to that?

I took a video of of what happen after the update to show what the LCD shows and how the GUI is affected. Could I mail it to you to see?

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 07:26 #76558 by vlad_vy
Replied by vlad_vy on topic Devo 10 Deviation v5.0.0 GUI on RC size
What v5.0.0 do you use? Nightly builds or anything else?

Try different build based on v5.0.0 release:
www.deviationtx.com/forum/builds/6407-de...cols?start=500#75331

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 07:28 #76559 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
I dont use the nightly build. Just proper v5.0.0 for Devo 10

Please Log in or Create an account to join the conversation.

More
02 Jul 2020 07:29 #76560 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
I will try the different build you suggest.

Please Log in or Create an account to join the conversation.

More
03 Jul 2020 00:35 #76562 by Mack775
Replied by Mack775 on topic Devo 10 Deviation v5.0.0 GUI on RC size
I have used those bilds on 5 devo 10 s and no problem. Just rember to use safely remove from usb.

Have Fun Mack

Please Log in or Create an account to join the conversation.

More
10 Jul 2020 11:26 #76576 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
Hi Vlad.

I tried to use the different build but it still makes the GUI on the menu the wrong scale so I am not able to see the transmitter menu.

To format the devo 10, do I just format it via Windows after I back the models up? Is there any particulare partitioning I must use? Like FAT32? Or just a regular "Right Click" Format drive?

Please Log in or Create an account to join the conversation.

More
10 Jul 2020 11:54 #76577 by vlad_vy
Replied by vlad_vy on topic Devo 10 Deviation v5.0.0 GUI on RC size
Use a regular "Right Click" Format drive. Select "Quick Format" option.

Please Log in or Create an account to join the conversation.

More
10 Jul 2020 14:56 #76579 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
Thank you.
I did the format.
Installed the V5 Nightly build.
Copied over the new library from the nightly build folder as well as my model backup.
The issue still occurs.
I reinstalled V4.0.1 and it works normally.
I really dont know what to make of this

Please Log in or Create an account to join the conversation.

More
11 Jul 2020 14:02 #76580 by Mack775
Replied by Mack775 on topic Devo 10 Deviation v5.0.0 GUI on RC size
Have you tried with out copping backup over?

Please Log in or Create an account to join the conversation.

More
11 Jul 2020 18:17 #76581 by Wilcox
Replied by Wilcox on topic Devo 10 Deviation v5.0.0 GUI on RC size
Hi Mack.
Yes I have tried that as well.
I will just use V4.0.1. At least I can see the menu and navigate the GUI on theDevo 10 with it.

Please Log in or Create an account to join the conversation.

More
11 Jul 2020 19:27 #76582 by Mack775
Replied by Mack775 on topic Devo 10 Deviation v5.0.0 GUI on RC size
I can't understand what is going on. I do the flashing for this area and never had any trouble with the devo 10. Messed up devo.fs on devo F7 once and GUI was messed up but never on devo 10. Had to reinstall devention and start over to get it to work. They are some very nice people on this forum, I bet someone has an idea. Good luck Mack

Please Log in or Create an account to join the conversation.

Time to create page: 0.057 seconds
Powered by Kunena Forum