Jumper T8SG v3 Carbon ELRS CRSF CONFIG BLACK BAR

More
13 Aug 2022 10:11 #78041 by vanuatuian
So I have noticed there has been a couple other threads kind of similar to this one but I found them a little hard to follow, and the links provided didn't always exist anymore.
I'm getting this issue where on my Radio when i go to the crsf config menu im presented with a solid black line where the text should be saying my modules name, I was reading somewhere this could be due to a word limit? but really im not sure how to rename the modules name if that is the case.
video of me navigating to the menu with the issue: youtube.com/shorts/_wSON8ZY7Nk

Things I have done:
- I have my Jumper modded by clipping one of the pins off and soldering the signal to the other end pin like they do in the crossfire mod.
- I have flashed my Jumper radio to the latest nightly build "deviation-t8sg_v2-v5.0.0-c84450e" and copied over the files over via usb transfer mode like the guy did in the video:

- and I have also flashed the latest firmware onto my Happymodel 2.4g ELRS ES24TX. and unchecked UART_INVERTED
- on the happymodel es24tx board i have them on the bottom 2 pins, but I have also tried them middle 2 and top 2 with the same results.

Any kind of advice or help would be greatly appreciated.

Cheers!

Please Log in or Create an account to join the conversation.

More
14 Aug 2022 22:34 - 14 Aug 2022 22:35 #78042 by hexfet
Unfortunately the official nightly builds are not working. Download the latest t8sg_v2 firmware here . This firmware has better support for ELRS and multiple fixes, including for the long name issue.

Jumper setting information is here .
Last edit: 14 Aug 2022 22:35 by hexfet.

Please Log in or Create an account to join the conversation.

More
15 Aug 2022 10:06 #78043 by vanuatuian
Replied by vanuatuian on topic Jumper T8SG v3 Carbon ELRS CRSF CONFIG BLACK BAR
That download link worked for me, problem solved now!

Thank you

Please Log in or Create an account to join the conversation.

More
20 Aug 2022 14:59 #78049 by Fernandez
Replied by Fernandez on topic Jumper T8SG v3 Carbon ELRS CRSF CONFIG BLACK BAR
Hmm I have got same issues, use happymodel slim, changed jumpers, flashed flashed over uart with latest 3.0 RC2 ELRS, left UART inverted tick box Open.

Updated TGSG V2 plus, with above build.
Connected to my pin changed external bay, but I get a black menu in CRSF.
I can change the baud setting, but nothing happens.

Please Log in or Create an account to join the conversation.

More
21 Aug 2022 00:03 #78050 by vanuatuian
Replied by vanuatuian on topic Jumper T8SG v3 Carbon ELRS CRSF CONFIG BLACK BAR
not sure if this will help, but for me i have the carbon edition radio and i found this version "deviation-t8sg_v2-v5.0.0-60968b7" worked for me in the above link. i was originally using deviation-t8sg_v2_plus-v5.0.0-60968b7 and it was giving me weird artifacts all over my screen.
good luck!

Please Log in or Create an account to join the conversation.

More
23 Aug 2022 18:34 - 23 Aug 2022 18:35 #78058 by Fernandez
Replied by Fernandez on topic Jumper T8SG v3 Carbon ELRS CRSF CONFIG BLACK BAR
Hi yes I did try that but not worked for me. I use the 1st generation, Happymodel 2.4g T-lite model.

I heard also something about long system name, but not clear how to check or change.
Last edit: 23 Aug 2022 18:35 by Fernandez.

Please Log in or Create an account to join the conversation.

More
24 Aug 2022 15:09 #78060 by hexfet
You said you have a T8SG V2 Plus, so you should be using the t8sg_v2_plus build. I think you are since you don't mention any display issues.

The long name problem is fixed in the build above so that's not the problem. You said you're using a T-lite module, which doesn't fit the T8SG JR bay. If you made a cable to connect them that would be something to check.

The ELRS version must be 2.X or above. The 1.X version used a different configuration system.

Please Log in or Create an account to join the conversation.

More
24 Aug 2022 18:21 - 24 Aug 2022 18:22 #78063 by Fernandez
Replied by Fernandez on topic Jumper T8SG v3 Carbon ELRS CRSF CONFIG BLACK BAR
The Tx is t8sg V2 plus (yellow)
The module is, the very first, oldest generation Happymodel; www.getfpv.com/happymodel-expresslrs-2-4...e-jumper-t-lite.html
I run indeed short external cable to the module bay; Gnd, 5v, signal.
I run firmware as posted.
ELRS is very latest 3.0

Menu is not loading, can only set the baudrate, tried different rates. indeed all other menues etc deviation tx seem fine.
Last edit: 24 Aug 2022 18:22 by Fernandez.

Please Log in or Create an account to join the conversation.

More
27 Aug 2022 16:50 #78064 by hexfet
Does your ELRS link work other than the configuration? The channels and telemetry are okay? If not then none of the serial data is getting through. If those work and the config does not then it's something else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.043 seconds
Powered by Kunena Forum