Deviation 5.0 has been released

More
06 May 2016 20:18 #47901 by HappyHarry
Replied by HappyHarry on topic Deviation 5.0 has been released
glad to hear it's working bud, and yeah it's friday so everything is ok :D

Please Log in or Create an account to join the conversation.

More
07 May 2016 09:56 #47954 by McQuack
Replied by McQuack on topic Deviation 5.0 has been released
Hi Arnold!, the dials are the AUX6 and AUX7, Aren't they?. They are totally funcional, I take the TX and give them the channel five and work properly without problems

Please Log in or Create an account to join the conversation.

More
21 May 2016 22:57 #48986 by NutraBind
Replied by NutraBind on topic Deviation 5.0 has been released
Kudos to all contributors of 5.0
I have installed it both on my Devo 7e and 10. Quick tests are all clear, I'm happy.

Please Log in or Create an account to join the conversation.

More
24 May 2016 08:56 #49112 by Zaphod
Replied by Zaphod on topic Deviation 5.0 has been released
Thanks to all involved in this amazing project!

Please Log in or Create an account to join the conversation.

More
29 May 2016 00:55 #49454 by lakodathecat
Replied by lakodathecat on topic Deviation 5.0 has been released
I'm having problems with getting the version 5 upgraded from version 4.0.1. I've been using 4.0.1 nightly. I'm stuck in after copying the new version 5 to the devo 10 it still says version 4.0.1. I've read the steps mentioned earlier in this post. I've tried running all the programs to try to install the version 5 firmware but problem I'm having is none of the tools/programs will not recognize my devo 10 so they will not run (DeviationUpload-0.8.0 or DevoDfuSe). It shows no transmitter. Things is I'm not sure what to trouble shoot since my devo 10 already has version 4.0.1 on it and maybe I'm not using the correct procedure or my devo 10 is messed up. The devo 10 will go to usb mode so I can copy files in windows. So to help me troubleshoot, what tool or program do I use to get the new firmware from 4.0.1 to 5? If I know exactly I can then try to get the program to recognize my devo 10. I'm confused about upgrading from 4.0.1 to 5 not installing deviation for the first time.

Please Log in or Create an account to join the conversation.

More
29 May 2016 01:11 - 29 May 2016 01:14 #49458 by HappyHarry
Replied by HappyHarry on topic Deviation 5.0 has been released
to upgrade is almost exactly the same method as installing deviation for the first time, the only real difference is makimg a backup of all your model.ini's before you start, then do as you would as if installing for the first time, so put the tx into programming mode by holding ext while powering on, then use dfuse or deviation-upload to upload the dfu, when that's complete turn off the tx then turn it on while holding ent to enable the usb drive, then copy across the filesystem contents that was included in the 5.0 download, then copy your model.ini's back into the models folder, edit the hardware.ini for any changes you have made to the tx and your done :)
Last edit: 29 May 2016 01:14 by HappyHarry.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 15:14 #50401 by Mike
Replied by Mike on topic Deviation 5.0 has been released
I installed version 5.0.0 on my Devo 7e. And although I first thought there were no problems I found a glitch: the buzzer and vibration do not work. After I noticed this I thought it was a hardware problem (tx had banged against the floor) but flashing back to 4.0.1-2cde795 which I used before going to 5 solved it. Upgrading to 5.0.0-c07562a made the buzzer silent again.
If this is due to limitations of the 7e I understand and I'll just stick to version 4. I really like the form factor and it also fits my sons little hands. To bad that all small TX's seem targeted as budget hardware. I'd happily pay for Devo 10 hardware in a 7e shell :-)

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 19:04 #50412 by HappyHarry
Replied by HappyHarry on topic Deviation 5.0 has been released
the buzzer and vibration is working ok in my 7e's so I've no idea what to suggest other than checking the buzzer volume is high enough and vibration is turned on.

as for the 10 hardware in the 7e have a look at tge ultimate7e threads as that's exactly what they are

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 20:06 #50420 by mwm
Replied by mwm on topic Deviation 5.0 has been released

Mike wrote: I'd happily pay for Devo 10 hardware in a 7e shell :-)


The 8 hardware - which is the 10 hardware minus AUX4 & AUX5 and with a color touch screen - is what you get in the 6, which has the 7e form factor. They failed to connect the two extra switches & trim button pairs on the 8, but left the connectors on the PCB. Adding those is supported in 5.0.0. Or you can add more switches instead of trim buttons, and different combinations of switches.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 22:14 - 11 Jun 2016 22:15 #50434 by Richard96816
Replied by Richard96816 on topic Deviation 5.0 has been released

Mike wrote: ...
I really like the [7e] form factor and it also fits my sons little hands. Too bad that all small TX's seem targeted as budget hardware. I'd happily pay for Devo 10 hardware in a 7e shell :-)


I like the 7e size too. Even smaller would be better, but it's not bad. All the others seem monstrously large. Reminiscent of (mostly empty) tower computers.

Why hasn't miniaturization caught up with R/C controllers? I want one the size of a thick cell-phone. With appropriately sized switches, knobs and full-sized folding sticks. (With tiny gimbals, of course.) :-)

Apologies for OT.
Last edit: 11 Jun 2016 22:15 by Richard96816.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 23:23 #50439 by aMax
Replied by aMax on topic Deviation 5.0 has been released

Mike wrote: I installed version 5.0.0 on my Devo 7e. And although I first thought there were no problems I found a glitch: the buzzer and vibration do not work. ..............snipp

No problem here with Deviation Ver 5.0.0 on the 7e. Buzzer and vibration are working as before. Copied my old tx.ini after flashing the firmware.

Devo7e, TaranisQ X7, R9M , 4in1 MM, Futaba FC18plusV3.2 & DFT/FLD-02

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 00:10 #50441 by vilaca
Replied by vilaca on topic Deviation 5.0 has been released
I would like to thank everyone involved for this new release.

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 01:24 - 12 Jun 2016 01:24 #50446 by mwm
Replied by mwm on topic Deviation 5.0 has been released

Mike wrote: I like the 7e size too. Even smaller would be better, but it's not bad. All the others seem monstrously large.


Two reasons: some people don't like the small size - they feel it makes them harder to hold/control. And there isn't a lot of convenient places to put switches, knobs, dials, sliders and the like on the things. The combination of these two things leads to even larger transmitters, like the Taranis X9E being popular with some people.

Personally, I like the smaller size for portability, when I'm flying less sophisticated aircraft and the switches on my 6S (after adding the extra trim button pairs) are fine. But for more sophisticated aircraft, I really want more controls than will comfortably fit on it, and the 10 is better. Though I really want a slider for jib tuning.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.
Last edit: 12 Jun 2016 01:24 by mwm. Reason: Remove extra open quote

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 18:01 #50479 by Mike
Replied by Mike on topic Deviation 5.0 has been released
HappyHarry: after your reply I flashed my 7e and ticked the format box. The beeper and vibration now work with version 5. Weird, probably some corruption somewhere as I checked and buzzer and vibration were on in version 5 when they failed. Thank you for saying it worked on your 7e, it convinced me that it really was something specific to mine. Now busy putting back the backed up files one by one to check if it's the hardware.ini or one of the model files.
That Ultimate7e is tempting :-). I do have a hot air station and a bit of experience with it. Only thing keeping me from it is that the 7e is my daily use and I would be very sad if I fubar it. I might get an other 7e as the Devo6 which mwm posted about seems end of sale.

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 23:43 #50498 by HappyHarry
Replied by HappyHarry on topic Deviation 5.0 has been released
glad to hear you got it working bud, there are still one or two places you can find the devo6, but they are too expensive imo. yeah it would be tough to loose your main used tx, but with the price of the 7e just now (~$45-50 shipped) a second one wouldn't go wrong to have as a backup :)

Please Log in or Create an account to join the conversation.

More
13 Jun 2016 00:23 #50505 by caughron01
Replied by caughron01 on topic Deviation 5.0 has been released
How do I downgrade back to 4.0.1? For my use doesn't seem that 5.0 is going to work for me.

Please Log in or Create an account to join the conversation.

More
13 Jun 2016 00:27 #50507 by HappyHarry
Replied by HappyHarry on topic Deviation 5.0 has been released
5.0 is really no different functionally wise to 4.0.1, but it's the same process you used to upgrade, just using the 4.0.1 files instead of the 5.0 ones

Please Log in or Create an account to join the conversation.

More
13 Jun 2016 00:32 - 13 Jun 2016 00:41 #50508 by caughron01
Replied by caughron01 on topic Deviation 5.0 has been released
Well my lcd display is a little different now (I have two timers set up and one of them, the bottom part of the numbers is cut out), and my inductrix file no longer works it binds ok but no flight at all. So I was thinking something with the 5.0 maybe

The 4.0.1 does not have an UPDATING.md file do I use the one from the 5.0?
Last edit: 13 Jun 2016 00:41 by caughron01.

Please Log in or Create an account to join the conversation.

More
13 Jun 2016 02:09 #50519 by mwm
Replied by mwm on topic Deviation 5.0 has been released
UPDATING.md is just a text file for you to read. You don't need it at all to update. If you're looking for instructions on how to update, then you need to check the 4.0.1 manual, if you can find one. Butt the only real difference is that 4.0.1 doesn't have a "hardware.ini" file, so you don't need to save that.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
14 Jun 2016 00:41 #50571 by caughron01
Replied by caughron01 on topic Deviation 5.0 has been released
Ah gotcha. Thanks lol still learning. I have upgraded to 5 and now the latest nightly build still getting the "missing module nrf24l01" Now I am starting to wonder if the module is having issues or is not installed correctly. I bought it this way and did not install the module.

Please Log in or Create an account to join the conversation.

Time to create page: 0.077 seconds
Powered by Kunena Forum