Jumper T8SG Plus V2/V3 FINALLY solved USB issues

18 Jan 2021 08:23 #77184 by damien59
So, after weeks, and weeks, of reading everything possible online, watching videos, calling support, troubleshooting with multiple PC's, cables, batteries, and pulling my hair out, I have finally reliably connected my Jumper T8SG Plus to my windows 10 pc, and wanted to share what I've learned along the way. What didn't work for me: Jumper T8SG Plus V3 restore guide, which you can find online, but it was the right direction. After this controller DID successfully work for 1 night, the following day, back to not working.

My problem: in USB Disk mode, it would never mount, so I could never copy files to/from it, even though the USB symbol showed on the remote, and when plugging into my pc, I got the normal windows sound I get when connecting an external usb drive. . .. also, even though, the remote showed up under Devices and printers (push windows +R then type in "control printers" without the quotes), this opens up devices and printers. When this remote is plugged in, and you've selected USBHID as the protocol in the remote settings, you SHOULD see Deviation GamePad, BUT in my case, when I got properties from that, instead of showing the controller as Deviation GamePad, it would be blank, or worse, show the vJoy driver from SmartPropoPlus I had installed......

So, firstly, Uninstall Smart PropoPlus (which most people end up installing as a workaround to use the sound input jack to link with the remote. . . . ) , this should uninstall the vJoy driver stuff also.... then restart, even after this... the game controller window wouldn't show a controller when plugged in .... aggravating..

So, when you plug in the controller, and look under Device Manager (push the windows key, type in device manager) you SHOULD see Deviation GamePad, get properties, Some people here are able to select Update Driver, then choose have disk, then browse for new driver (you can google www.liftoff-game.com/sites/default/files...ote-USB-Driver_0.pdf )...... BUT this didnt work for me, I tried over and over to update the damn driver... restarting, waiting, nada....

But the controller DOES work on my laptop, so I kept pushing on, I knew it had to work.... MY SOLUTION... stupid as it sounds.... instead of pushing UPDATE DRIVER, I pushed UNINSTALL DEVICE on the same window... figured it couldn't get any worse....
plugged back in and WOOOOHOOOO its fixed.....
only took around 20 hours of scouring the web and troubleshooting, lol So, if you follow the attached PDF, step 9, Update Driver, if that doesn't work for you, then Uninstall Device, restart, and all should be fine.

Hopefully this helps out other people... was quite the Pain in the A$$.

This browser does not support PDFs. Please download the PDF to view it: Download PDF


Please Log in or Create an account to join the conversation.

Time to create page: 0.024 seconds
Powered by Kunena Forum