Working build for Devo10 for AFHDS 2A & FrSky LBT

More
14 Apr 2021 14:06 #77342 by Girts
At last tried to update DEVO10 for use with AFHDS 2A and FrSky LBT. Last official build is 5.0.0. released 2016, does not have possibility to use them. Last nightly build (deviation-devo10-v5.0.0-c84450e 2021-04-13) reverted strange screen and periodic restart (see attached images). Previous nightly build (deviation-devo10-v5.0.0-28ce50f, released 2019) is not accessible.

Could anybody share working build for DEVO10 with AFHDS 2A and FrSky LBT?

Thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
15 Apr 2021 03:03 #77343 by Gerry
you could try the Vlad_vy build for Devo10 found in this post
www.deviationtx.com/forum/builds/6407-de...cols?start=480#75331

Devo 7e A7105 NRF24L01 CC2500 2x3 way & voice, Devo 12e 4 in 1 & voice.
FFS (Forever Fixing Stuff)

Please Log in or Create an account to join the conversation.

More
15 Apr 2021 03:20 - 15 Apr 2021 03:21 #77344 by mj666
For me latest nightly is working well for Devo, DSMX, and the various FrSky D/X protocols. I'm not using the AFHDS 2A protocol. I use multiple Devo10 transmitters with this build.
Last edit: 15 Apr 2021 03:21 by mj666.

Please Log in or Create an account to join the conversation.

More
15 Apr 2021 22:05 #77346 by Girts
Thanks Gerry, this build works, at least with AFHDS, FS-A8S v2. Up to now can not find how to set failsafe. Will keep trying ;)
In this build there is FrSkyX. Tried to bind with FrSky XM+, but without success :dry:

mj666, which latest build do you mean? data? link?
2021-04-13 build (c84450e) reverted strange screens, please find attached to first post.

Please Log in or Create an account to join the conversation.

More
16 Apr 2021 00:56 #77347 by ajtank
Normally I only updated the DFU file for nightly builds.
However I recall a long time ago I had to copy the media folder to solve a similar issue like yours.
I do not know if the same trick will work or not for your case.

Please Log in or Create an account to join the conversation.

More
16 Apr 2021 03:49 - 28 Apr 2021 03:28 #77348 by mj666
I'm runing the last nightly from the Deviation Web site. Be sure you also update the content of your flash memory when you come from an older build. You can make an backup before, to be able to revert later on if needed.

There is an issue with XM+ v2.1.2 wich will not bind but with a firmware v2.1.0 or below it should work. I have a privat build in testing which fixes the v2.1.2 issue based on the latest nightly and the fix from the MPM code.

Girts wrote: Thanks Gerry, this build works, at least with AFHDS, FS-A8S v2. Up to now can not find how to set failsafe. Will keep trying ;)
In this build there is FrSkyX. Tried to bind with FrSky XM+, but without success :dry:

mj666, which latest build do you mean? data? link?
2021-04-13 build (c84450e) reverted strange screens, please find attached to first post.

Last edit: 28 Apr 2021 03:28 by mj666.

Please Log in or Create an account to join the conversation.

More
16 Apr 2021 08:12 #77352 by Girts
Thanks mj666, will try to update other, not only .dfu

How do you flash XM+ with DEVO? I only saw instructions on YT how to flash with TARANIS X9. I am not wise in PC and coding things :(

Please Log in or Create an account to join the conversation.

More
16 Apr 2021 17:42 - 16 Apr 2021 17:43 #77355 by mj666
The Devo can not flash receivers. You need to use other methods to do so.

Girts wrote: Thanks mj666, will try to update other, not only .dfu

How do you flash XM+ with DEVO? I only saw instructions on YT how to flash with TARANIS X9. I am not wise in PC and coding things :(

Last edit: 16 Apr 2021 17:43 by mj666.

Please Log in or Create an account to join the conversation.

More
19 Apr 2021 06:31 #77358 by Girts
Thanks mj666
Which version should be used for DEVO? no-EU?

Please Log in or Create an account to join the conversation.

More
20 Apr 2021 03:26 - 20 Apr 2021 05:55 #77359 by mj666
This is really up to you. The Devo will be able to bind to any of the different FrSky RX firmware variants with the proper settings. Anyhow it would be more practical to agree to one. V1 protocol has some issues which may affect you in crowded 2.4GHz environments. Likely for you V2 FCC version would be preferred.

Girts wrote: Thanks mj666
Which version should be used for DEVO? no-EU?

Last edit: 20 Apr 2021 05:55 by mj666.

Please Log in or Create an account to join the conversation.

Time to create page: 0.044 seconds
Powered by Kunena Forum