Devo 7E NRF24lu1 dissapointing range (30M) problem

More
17 Apr 2017 16:03 #61526 by Appelmoesman
I have tested two NRF modules that do not provide enough range for me to fly my quads reliably.
I fly brushless Bayang protocol SilverX H8 mini receiver boards FPV.

I use this banggood "1100 Meter Long Distance NRF24L01+PA+LNA Wireless Module With Antenna" >>module

The PA+LNA version should give me more range that i'm currently getting (ofcourse not 1100....)
*I checked the Hardware INI for PA enabled
*the module is receiving a stable 3,3V when operating
*the new module has the same range problem
*shielding does not improve the range
*the TX power is set at 150mw
*my A7105 chip gets 300 meters with AFHDS2A

Questions: Does the CYRF mod affect the range of the NRF24 module
What do I need to change to get more power out of this lousy contraption
Why am I not getting some decent range...?
When I walk out of the door of my appartment I lose connection (10meter) 30M outside





This was the module that I changed out because I expected a problem with the board



Range seemed worse then with Version 4.something Im getting less range with 5.00

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 09:27 #61542 by Fernandez
I am running Eachine H8 with silverware and deviation 5.00 on devo U7e and even on 1mw I can do 30m even in our building with wifi.
Maybe your module is broken or antenna has a short etc.

I made a smal RF detector tool, using Rf diode, C and 100uA analog meter, you can just keep it in front of any TX and it gives indication of radiated power. I find easy and usefull. (Also use it for VTx)

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 12:04 #61546 by Appelmoesman
Replied by Appelmoesman on topic Devo 7E NRF24lu1 dissapointing range (30M) problem
yes when you look at the chip connected to the huge 5dbi antenna when I take of that micro sma connector and touch the ground with my multimeter and signal with the other I get absolutely zero resistance and it starts to beep inmediately... Same for my new model... THe CYRF and the A7105 I have installed Absolutely do not have signal connected to ground..... So WTF?? how to stop signal connecting to ground on these NRF24 modules Im willing to destroy some traces that destroy this connection..... im pretty sure my problems are caused by this...

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 12:13 #61548 by Appelmoesman
Replied by Appelmoesman on topic Devo 7E NRF24lu1 dissapointing range (30M) problem


All antenna connections and connectors in these pictures show ground connections.... WTF...
im going to desolder the 29MM dipole and try so break signal free of ground while leaving one pad... im using some banggood schematics to do so... lets hope range problems are fixed by doing this... my cyrf and A7105 modules have no signal to ground short...
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 13:27 - 18 Apr 2017 13:44 #61551 by aMax
I don´t know how your joint is, but using only two pads of the throughwhole version, I had a great working module.
www.bilder-hosting.info/viewer.php?id=arx1399946310k.jpg

Btw, why do you use this useless 150mW setting? The PA/LNA chip is the same on your module and even the used protiocol.
www.deviationtx.com/forum/7-development/...dule?start=900#54814

Devo7e, TaranisQ X7, R9M , 4in1 MM, Futaba FC18plusV3.2 & DFT/FLD-02
Last edit: 18 Apr 2017 13:44 by aMax.

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 15:36 #61554 by Arakon
Some RF modules pull the antenna pin to GND while it's powered off.. happens on video transmitters too, for example. Check while it has power.. careful not to cause a short circuit, of course.

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 17:00 #61556 by Appelmoesman
Replied by Appelmoesman on topic Devo 7E NRF24lu1 dissapointing range (30M) problem
*i've shielde the module
*re-done the wiring (hacksmods again..)

*tried a Laptop 2,4ghz antenna
*added a capacitor (330uF 6,3V low ESR)
*I only found difference between 1mw and 3mw in reception when I put my hand around the antenna and put my body inbetween I lose connection when im in the next room (8M)
from 3-30MW this happens

To show how bad this is... I never lose connection even on 100uW I don't lose connection when shielding the antenna of my X210 with my hand pushing then together in the next room with my body in between and the carbon fiber in between... connection cant be broken that way.... (using th A7105 chip and afhds2a)...

What the hell is wrong until I find out my brushless FPV quads will be grounded and remain in LOS service.. its just not worth it increasing throttle without being able to steer back towards myself.

My CSN is connected to TCK does this matter?
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 19:30 #61558 by Fernandez
you could probably measure the current from the module, putting ma amp meter between the Vcc of module. If the PA is working the consumed current of the module should go up selecting more output power in deviation. If so you can assume that the PA stage is working and not burned.

On measuring RF shorts is difficult to tell if is a fail, as a coil can be measured as a short circuit for DC, but for AC it is not.

Possibly just put new antenna or just a small piece of wire, maybe there is a short in the antenna or connection of coax.

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 20:56 #61561 by aMax

Appelmoesman wrote:


cut

My CSN is connected to TCK does this matter?

If you set this right in your hardware.ini, possibly not.
Did you bind CE with a pullup resistor to VCC?

Devo7e, TaranisQ X7, R9M , 4in1 MM, Futaba FC18plusV3.2 & DFT/FLD-02

Please Log in or Create an account to join the conversation.

More
18 Apr 2017 22:50 - 18 Apr 2017 22:51 #61566 by Appelmoesman
Replied by Appelmoesman on topic Devo 7E NRF24lu1 dissapointing range (30M) problem
Hardware ini is set OK:
; enable-cyrf6936 = B12
has_pa-cyrf6936 = 0
enable-a7105 = A13
has_pa-a7105 = 1
; enable-cc2500 = A14
; has_pa-cc2500 = 1
enable-nrf24l01 = A14
has_pa-nrf24l01 = 1

Can you explain me the pull up resistor? CE to VCC?
Do you have it installed like that? I have CE and VCC connected. adding a resistor wont do anything

I used the hacksmods pinout pictures... are they wrong? www.hacksmods.com/2013/05/nrf24l01-devo7e-pinout/
I later found out that I had the A7105 wrongly installed and it increased range considerably
Last edit: 18 Apr 2017 22:51 by Appelmoesman.

Please Log in or Create an account to join the conversation.

More
19 Apr 2017 00:11 #61569 by aMax
If you have done it this way, ok..The resistor is only a current limiter which I used to avoid occasional screen distorsion on boot time.

Devo7e, TaranisQ X7, R9M , 4in1 MM, Futaba FC18plusV3.2 & DFT/FLD-02

Please Log in or Create an account to join the conversation.

More
22 May 2018 15:11 #69367 by sier
I have the exact same issue and it’s driving me nuts.

Was this resolved? And if, how?

Please Log in or Create an account to join the conversation.

Time to create page: 0.305 seconds
Powered by Kunena Forum