Restore or backup original DEVO 7E firmware

More
06 Dec 2015 18:06 #40632 by Karmabim
I wonder if anyone can help?
I have just installed the NRF24L01 module in my new Devo 7E but before I install the deviation firmware I would like to have a copy of the existing devention firmware, just in case of any problems.
Is there a way to backup the existing firmware? It appears to be on Firmware Ver. 0.2, Library Ver. 0.1. Or does anyone know where to download the Walkera firmware? It doesn't appear to be supported on their website any longer.

Thanks in advance to anyone who can advise.

Please Log in or Create an account to join the conversation.

More
06 Dec 2015 19:21 - 06 Dec 2015 19:29 #40635 by RedSleds
Replied by RedSleds on topic Restore or backup original DEVO 7E firmware

File Attachment:

File Name: Devo7EFirmware0.2.zip
File Size:156 KB


....or here on the deviationtx site www.deviationtx.com/links , which links to Google Drive.

drive.google.com/folderview?id=0B3y72n5Y...jTkZvTFpPU1MxTDRGTnc

DEVO 10 - Multi-module with nRF24L01 +PA +LNA, A7105 +PA, & CC2500 +PA +LNA transceivers.
Nightly Build: v4.0.1-548bbf5 (6/9/2015)
Attachments:
Last edit: 06 Dec 2015 19:29 by RedSleds.

Please Log in or Create an account to join the conversation.

More
07 Aug 2016 06:39 - 07 Aug 2016 12:10 #52525 by Chambers
Replied by Chambers on topic Restore or backup original DEVO 7E firmware
I have tried to revert back to stock firmware I have both files as above (firmware ver 0.2 and library 0.1 I also read to "UPDATE" the tx not "upload" which I have done, all goes well until I reboot the radio and the gfx on the screen are all messed up, if I press buttons I can tell something is happening but there is no text or anything just graphics. Now I cant even get it to bind with my Walkera F210-3d!!! I have a Devo7 with a damaged antenna but it still binds to the F210 it's like the Devo7e is not transmitting a signal. I had everything working fine yesterday on the stock firmware... now I cant get deviation to work nor can I get back my old Devention firmware
Last edit: 07 Aug 2016 12:10 by Chambers. Reason: edited

Please Log in or Create an account to join the conversation.

More
07 Aug 2016 12:18 #52534 by Thomas.Heiss
Replied by Thomas.Heiss on topic Restore or backup original DEVO 7E firmware
walkera-fans.de/download/sender/Devo_7E/...20Firmware%200.2.zip


Why can't you get Deviation to work?
What is the concrete problem?
Try a reflash with Deviation release 5.0.

If that really fails with Walkera Dfuse try to the different java loader util.

Please Log in or Create an account to join the conversation.

More
07 Aug 2016 12:33 - 07 Aug 2016 12:33 #52536 by mwm
You may need to update the library as well as the firmware to get the original firmware to work again. Broken graphics are what happens on some of the other Tx's when you don't do that. Not sure that's the case with the 7e, though.

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.
Last edit: 07 Aug 2016 12:33 by mwm.

Please Log in or Create an account to join the conversation.

More
07 Aug 2016 12:44 #52538 by Thomas.Heiss
Replied by Thomas.Heiss on topic Restore or backup original DEVO 7E firmware
Is the range with the 7E (range limitation by hardware diode ~7mw, <10mw) really even enough for a F210???
Did you do a 7E hardware mod?

Devo10 or Devo7 which are sold for Walkera Furious 320 or F210 are full range within EU/DE and use e.g 10mw output power.
For Non-EU you get the A firmware version (instead of B) which uses 100mw instead of 10mw (Devo = 3 channel DSSS protocol).

Please Log in or Create an account to join the conversation.

More
07 Aug 2016 16:00 - 07 Aug 2016 16:27 #52545 by Chambers
Replied by Chambers on topic Restore or backup original DEVO 7E firmware
I have tried 5.0 and also the Lib files but the .Lib files dont seem to be copying over, if I load the old devention firmware I cant get to the USB screen by holding the "ent" button. I have tried uploading and updating the library to no avail. I can get deviation 5.0 installed but it will not bind to the f210 and when I look in cleanflight under reciever nothing moves on stick/button input, I'm aware of the range limitation this is just a back-up radio to fly in the park until my new antenna for my Devo 7 arrives, also my Devo 7 with the broken antenna will bind no problem (as long as I'm within 20 feet or so).
Last edit: 07 Aug 2016 16:27 by Chambers. Reason: spelling error

Please Log in or Create an account to join the conversation.

More
07 Aug 2016 20:18 #52553 by Thomas.Heiss
Replied by Thomas.Heiss on topic Restore or backup original DEVO 7E firmware
Your problem with Deviation 5.0 might be that you are quite new to the programming model.
If you are you might not have mapped the input sticks to the output channels.

Is there even a F210 model.ini file? If yes, have you downloaded it?
I could not find any model config on wiki or walkera-fans.de download section (not for DeviationTX - yet).

Please go into Deviation transmitter menu / channel monitor.
Do you see any channel movement when you move the sticks?
If that fails you will not see any moves / inputs in cleanflight.

I would guess it is "just a missing programming" thing?!? :-)

Please Log in or Create an account to join the conversation.

More
08 Aug 2016 04:49 #52566 by Chambers
Replied by Chambers on topic Restore or backup original DEVO 7E firmware
I am new to the radio and Deviation, however I did spend the best part of a day reading the manual and watching videos to no avail, Out of the box it was fine and was set up perfect until I though upgrading the firmware was a good idea... also reading I could revert back to Devention I thought it would be ok to just "try" it... no I have no .ini file, the channels movei n chammel monitor so I assume your right and the sticks need assigning to channels... I'll have to look into that however cleanflight the channels don't move (assuming because the craft is not bound? Thanks for your help.

Please Log in or Create an account to join the conversation.

More
13 May 2019 12:59 #74293 by ghenose
Replied by ghenose on topic Restore or backup original DEVO 7E firmware
Hi ! did you manage to reinstall the original DeVention firmare on Devo 7E? I tried to do it but it's not working. Hope you can help me!

Please Log in or Create an account to join the conversation.

Time to create page: 0.043 seconds
Powered by Kunena Forum