T8SG PLUS V3 Carbon black screen after upgrade

More
17 May 2022 22:49 #77987 by Fedebhrkz
good evening everyone, tonight after doing a firmware update to try to make my elrs module work on the t8sg v3 plus (lcd) the screen does not turn on anymore and the radio seems to be still in "dfu" mode, I can turn it on with power + enter or power + return that does not change anything, windows detects that it is attached but only as if it were in firmware update mode. I tried to flash other older firmware, even that of the dedicated jumper site, but nothing ... ideas? where am i wrong? thanks to those who will answer me, good night

Please Log in or Create an account to join the conversation.

More
18 May 2022 20:21 #77989 by tonh
What firmware did you install? You'd need this www.deviationtx.com/downloads-new/catego...2-v5-0-0-f6f940d-zip version.. (the non plus version)

Please Log in or Create an account to join the conversation.

More
19 May 2022 16:48 #77992 by Fedebhrkz
Replied by Fedebhrkz on topic T8SG PLUS V3 Carbon black screen after upgrade
il problema era il pulsante menu torna indietro che si e inceppato. ora la radio funziona perfettamente!
ora devo trovare il modo di far vedere alla radio il modulo erls... riesco a entrare come crossfire e il modulo viene alimentato ma non vedo i settaggi sulla radio :-( modifica hardware crsf fatta e flash firmware els fatto per t8sg... mi sa che sbaglio qualche passaggio o la radio non รจ perfettamente compatibile (su internet si riesce con la v2 Plus)

the problem was the menu button go back that got stuck. now the radio works perfectly!
now I have to find a way to show the erls module on the radio ... I can enter as crossfire and the module is powered but I don't see the settings on the radio :-( crsf hardware modification made and els firmware flash made for t8sg ... I know that I am wrong some steps or the radio is not perfectly compatible (on the internet you can do it with the v2 Plus)

Please Log in or Create an account to join the conversation.

More
19 May 2022 21:36 #77995 by tonh
If you did the mod, downloaded and flashed hexfet's latest firmware and flashed your elrs modules (which one do you have?) .. it should work. I've been flying elrs with that same radio for a over a year now..

Please Log in or Create an account to join the conversation.

Time to create page: 0.034 seconds
Powered by Kunena Forum