T8SG Lite

More
03 Jan 2019 15:02 #72192 by Qmike
T8SG Lite was created by Qmike
No startup screen anymore. I've got 2 choices: 1. DFU Mode or 2. USB Mode. So what to do?

Does anyone has a tip of how I can flash the RC to the old status back?

Like I sad before the only modes still working is ENT Button + ON/OFF to enable USB Mode or SEL Button + ON/OFF to enable DFU Mode.
File system is not accessable at all via desktop nor formatting possible.

Hope someone has a solution.

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 15:49 #72193 by Fernandez
Replied by Fernandez on topic T8SG Lite
Any deviation radio consist of two parts, the firmware file flashed to the Tx, using the bootloader tool.

Then in USB mode the Tx, works like a drive on this drive there is the filesystem inc model files settings files etc, all is needed to function properly.

When not closing the USB correctly or unplugging the file system can get corrupted. Prrobably this is what happened.
So in that case you have to, format the transmitter USB drive, default settings is fine, than copy the directories and file structure to the USB drive.

Disconnect using, windows disconnect USB, before unplugging.


You could put the latest nightly build, but better than also flqsh latest firmware.

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 18:57 #72194 by Qmike
Replied by Qmike on topic T8SG Lite
Hi Fernandez,

pretty quick reaction and thanks for giving me this explanation.

I have no access to the filesystem at all. Neither via Windows nor via Linux. Information I got is: system needs formatting.
Whenever I try to do that, command breaks with the comment: cannot access, formatting not finished.
I even changed the Flash-ROM on the board so I'm pretty sure that HW isn't the cause for that behavior.

I'm all ears for any further suggestion.

By the way I'm pretty disappointed about the reaction of jumper. This was a brand new RC and my Mail has not been answered yet.
I guess, next RC isn't Jumper anymore.

Cheers
Michael

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 19:06 #72195 by hexfet
Replied by hexfet on topic T8SG Lite
Go to the User Manual link in the left column for Devo 7e/10/12e (similar to t8sg). Follow the directions in the Installation section to do a fresh install of deviation firmware (available in the Downloads link). That should get the tx going as long as it's not a hardware problem.

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 22:20 - 03 Jan 2019 22:23 #72200 by Qmike
Replied by Qmike on topic T8SG Lite
Still strange behaivior. Press ON/OFF button shortly will put the red LED on but then goes off. Pressing the ON/OFF half a second, then it stays on and with a short delay the green LED turns on, too,

Can get in contact to the Radio via the DFU Utility but Upload Util does not work (only to "unknown" transmitter.

For today I'm giving up and I guess it is a more serious issue to solve.

Thks. hexfet & Fernandez for your first hints.

Maybe I make a short video to show of what is going on.

Cheers for today
Michael
Last edit: 03 Jan 2019 22:23 by Qmike.

Please Log in or Create an account to join the conversation.

More
08 Jan 2019 17:03 #72238 by Qmike
Replied by Qmike on topic T8SG Lite
(https://c.web.de/@337599667434952044/A3lyCU5RTvO0NYPOLi_Dlw)

Below this link a short video explains the situation.

In short: No access to the file system via USB. Any try to format filesystem new fails. Beside this you have access via DFU and USB. With the upgrade tool you never ever see a valid Device (either Devo 7 or Unknown)

Can anybody help? Does anyone have the binary files of the CPU to give it a try via ST-Link2?

I'm all ears.

Please Log in or Create an account to join the conversation.

More
08 Jan 2019 19:56 #72240 by hexfet
Replied by hexfet on topic T8SG Lite
Try downloading the driver Installer here . Install the Walkera driver, then see if the tx is recognized by Windows in DFU mode (EXT + power). If so perform a full install.

Please Log in or Create an account to join the conversation.

More
08 Jan 2019 21:44 #72244 by Qmike
Replied by Qmike on topic T8SG Lite
Your suggestion was one of the first things I did. Unfortunately without success. I can enter only via dfu mode the access to the java upgrade tool. Then I should see the actual device in the headline of the menue. The only device I see is either "devo 7" (default) or "unknown".

Please read my inputs above. By the way the explanation according to 7e I followed step by step. I cannot get access to the file system of the t8sg. Neither with the upgrade tool nor via the dfu tool. Seems that latest the access to the file system is complete blocked. I even checked on HW Layer to change the flash (in my case winbond 25q32) but that didn't worked either,

The only chance which comes into my mind is to flash the CPU ST32f303 with a new SW/firmware or whatever you call it. For me it seems that something in the inner softwarestack is corrupted out of whatever reason and so the communication in its fundamentals is disturbed.

If anyone has an idea of how to get it running again, I'm delighted.

Please Log in or Create an account to join the conversation.

More
09 Jan 2019 05:36 - 09 Jan 2019 05:39 #72245 by vlad_vy
Replied by vlad_vy on topic T8SG Lite
If you changed original flash chip to winbond 25q32 it can't be used with default stock or nightly t8sg_v2 firmware. By default t8sg_v2 firmware can use only SST25VF016B.

I can try to build for you custom firmware t8sg_v2 based on v5.00 core with flash chip auto detection, just for testing:

File Attachment:

File Name: deviation-...1-09.zip
File Size:659 KB


Now I can't locally build nightly builds, I don't know why.
Attachments:
Last edit: 09 Jan 2019 05:39 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
09 Jan 2019 05:52 #72246 by vlad_vy
Replied by vlad_vy on topic T8SG Lite
Sometimes corrupted t8sg filesystem (with original flash memory chip) can be completely inaccessible. You can try to cure it with custom build (t8sg_v2 or t8sgv2_plus), look at next topic:

www.deviationtx.com/forum/6-general-disc...-in-usb-mode?start=0

Please Log in or Create an account to join the conversation.

More
09 Jan 2019 07:37 #72247 by Qmike
Replied by Qmike on topic T8SG Lite
Hi vlad_vy,

did via dfu the upgrade of the modified file you provided. Shut off the device and tried to switch on again by pressing the ent button. This time no usb logo appears. Nevertheless access to file system is prohibited and a pop up screen asks for formatting. I see a different behaivior with repect to the reaction by pressing the on/off button and by entering the usb mode.

Please Log in or Create an account to join the conversation.

More
09 Jan 2019 09:17 #72249 by vlad_vy
Replied by vlad_vy on topic T8SG Lite
What file do you use? "deviation-t8sg_v2-v5.0.0-2019-01-09.zip" or from "T8SG v2 plus stuck in USB mode" topic?

Files from "T8SG v2 plus stuck in USB mode" can be used with original flash memory (SST25VF016B) chip only.

Please Log in or Create an account to join the conversation.

More
09 Jan 2019 12:00 #72250 by Qmike
Replied by Qmike on topic T8SG Lite
vlad_vy you respond pretty quick, thats super kind of you.
From what I see the SPI Flash is from Winbond 25Q32JV and don't forget we are talking T8SG Lite here.
So than the utility does not cover the content of the flash.

Your Utility addresses 16MB and the actual one 32MB, is that correct?

Do you have a solution for the other size?

Please Log in or Create an account to join the conversation.

More
09 Jan 2019 18:37 #72257 by Qmike
Replied by Qmike on topic T8SG Lite
Any chance to get a modified update covering the larger memory space?
By the way, does this influence the content to be downloaded, too?

Please Log in or Create an account to join the conversation.

More
10 Jan 2019 04:19 #72265 by vlad_vy
Replied by vlad_vy on topic T8SG Lite
Winbond 25Q32JV is 4MB (32Mb / 8 = 4MB)

Winbond space calculated as (Winbond 25Q32JV chip ID is 0x4016): spiflash_sectors = 1 << ((capacity & 0x0f) + 4); or 0x4016 & 0x0F = 0x06, 0x06 + 4 = 10, 2^10 = 1024, 1024 * 4096 = 4194304 bytes

Any other chip space will be calculated from Winbond chip ID.

Please Log in or Create an account to join the conversation.

More
10 Jan 2019 08:23 #72266 by Qmike
Replied by Qmike on topic T8SG Lite
Quick answer. Again thanks for you reaction.

I'm not a developer nor a sw specialist. I guess the sw has to be compiled by including those specs you have given. Is there an easy way to call a make instruction and the process will generate a binary file with the specs according to my HW? T8SG (lite) is (as far as I know) based on the same motherboard. This leads to similar definition for most of the HW. The difference might be the SPI ROM(Flash). Display, analog Ports and SW ports should stay the same.

Can you give me a helping hand how to set-up the compiling enviroment and show me the files that needs adaption?

Hope it works.

Please Log in or Create an account to join the conversation.

More
10 Jan 2019 09:30 - 10 Jan 2019 09:34 #72267 by vlad_vy
Replied by vlad_vy on topic T8SG Lite
www.deviationtx.com/wiki/development#building_the_code

You need modify source to enable flash memory detection. For T8SG Lite you can use t8sg_v2 target and for filesystem use original "hardware.ini" from your T8SG Lite.

github.com/DeviationTX/deviation

src\target\t8sg_v2\target_defs.h
#ifndef _T8SG_V2_TARGET_H_
#define _T8SG_V2_TARGET_H_

#include "../common/devo/common_devo.h"

#define TXID 0x7e
#define VECTOR_TABLE_LOCATION 0x3000
#define HAS_FLASH_DETECT 1
#define SPIFLASH_SECTOR_OFFSET 0

#define HAS_STANDARD_GUI    1
...
...
Last edit: 10 Jan 2019 09:34 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
10 Jan 2019 18:07 #72272 by Qmike
Replied by Qmike on topic T8SG Lite
Try to set-up the compiling enviroment and make the suggested changes. Maybe I go with Ubuntu to keep on PC for developments.

Can you give a hint in which file I have to put in the SPI flash information, the winbond one?

Please Log in or Create an account to join the conversation.

More
11 Jan 2019 05:33 #72273 by vlad_vy
Replied by vlad_vy on topic T8SG Lite
All you need => change target_defs.h file for t8sg_v2 and compile (make TARGET=t8sg_v2 zip). Modded firmware will autodetect flash memory chip (from supported list).

Please Log in or Create an account to join the conversation.

More
11 Jan 2019 16:02 #72279 by Qmike
Replied by Qmike on topic T8SG Lite
Container is set-up. does compiling for a selected device (e.g. T8SG_V2) but it seems that source is not local but online.
How can I change the source (e.g. target_defs.h)?

I like the idea with the container! Great thoughts behind to make even for dummies live easier!!!

I may sit down an explain my findings so far to help other overcome first hick-ups with the system.

I guess it was you who wrote that interrupts can cause a corrupted file system. It happend me by switching in parallel trimm and on/off button.

Please Log in or Create an account to join the conversation.

Time to create page: 0.069 seconds
Powered by Kunena Forum