Need testers for USBcode

More
02 May 2018 21:44 - 02 May 2018 21:44 #68984 by Moeder
Replied by Moeder on topic Need testers for USBcode
As the bootloader won‘t let us read arbitrary flash pages, the count fix is the way to go. But don‘t you think we should at least change the display of the recognized device? Devo7e is just plain wrong, and why not at least fix this for DeviationUploader, which should become the preferred (and also cross-platform) flashing tool?
Last edit: 02 May 2018 21:44 by Moeder.

Please Log in or Create an account to join the conversation.

More
03 May 2018 03:43 #68985 by vlad_vy
Replied by vlad_vy on topic Need testers for USBcode
I don't know. I never watch what transmitter is recognized.

Please Log in or Create an account to join the conversation.

More
03 May 2018 11:32 #68990 by Moeder
Replied by Moeder on topic Need testers for USBcode
I don't either, but we are not the majority of jumper users. Right now you could accidentally flash your devo7e with a 256 k firmware, I believe we should prevent this.

Please Log in or Create an account to join the conversation.

More
03 May 2018 11:52 - 03 May 2018 11:59 #68991 by vlad_vy
Replied by vlad_vy on topic Need testers for USBcode
We can use DfuMemory count =122 or count =116 to enable or disable specific devo7e firmware.
Last edit: 03 May 2018 11:59 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
03 May 2018 12:23 #68992 by Moeder
Replied by Moeder on topic Need testers for USBcode
That's what I mean. Could you do the changes? I do not like Java ;)

Please Log in or Create an account to join the conversation.

More
09 May 2018 19:25 #69148 by Moeder
Replied by Moeder on topic Need testers for USBcode
We pushed changes to master.
@FDR: can you upload Deviation-Uploader 0.9 to the appropriate Downloads section?

Please Log in or Create an account to join the conversation.

More
11 May 2018 08:17 - 11 May 2018 08:19 #69177 by vlad_vy
Replied by vlad_vy on topic Need testers for USBcode
Moeder, can you temporary upload it to Test Builds?

By the way, I think we need remove old test builds.
Last edit: 11 May 2018 08:19 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
12 May 2018 16:19 - 12 May 2018 16:19 #69190 by Moeder
Replied by Moeder on topic Need testers for USBcode
After PB fixed the upload script (thanks!) you can now find it here:
DeviationUploader 0.9
Last edit: 12 May 2018 16:19 by Moeder.

Please Log in or Create an account to join the conversation.

More
21 May 2018 20:15 #69360 by FDR
Replied by FDR on topic Need testers for USBcode
I uploaded it into its proper download section:
www.deviationtx.com/downloads-new/category/161-dfu-usb-tool#

Whoever has link to the temporary one, please correct it!

Please Log in or Create an account to join the conversation.

More
14 Jun 2018 02:23 #69636 by davdrone1
Replied by davdrone1 on topic Need testers for USBcode
Successfully ran this under Linux Mint 17.3
Had to update from Java 7 to Java 8 first.
After downloading DeviationUpload-0.9.0.jar I set it to executable, then ran it from terminal as root (sudo bash)
Would like to see the Transmitter name updated, but progress bar, and "Copy complete" message provides good feedback.
Now my ancient Win XP natebook can resume gathering dust again. Thanks.

Time flies like a banana
Attachments:

Please Log in or Create an account to join the conversation.

More
13 Sep 2018 09:57 #70871 by popad
Replied by popad on topic Need testers for USBcode
On windows 7 pro with last jre installed, command: java -jar DeviationUpload-0.9.0.jar

Exception in thread "main" java.lang.UnsupportedClassVersionError: deviation/Dev
iationUploader : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
1)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Could not find the main class: deviation.DeviationUploader. Program will exit.

What is wrong ? Thanks.

Please Log in or Create an account to join the conversation.

More
13 Sep 2018 11:14 #70872 by Moeder
Replied by Moeder on topic Need testers for USBcode
Java version issue, Jre 1.8 is required. Check the output of
java -version

Please Log in or Create an account to join the conversation.

More
13 Sep 2018 11:42 #70873 by popad
Replied by popad on topic Need testers for USBcode
C:\Windows\System32>java -version
java version "1.8.0_181"
Java(TM) SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.181-b13, mixed mode)

C:\Windows\System32>

Please Log in or Create an account to join the conversation.

Time to create page: 0.068 seconds
Powered by Kunena Forum