Deviation v5.0.0 build with latest protocols

More
18 Nov 2017 07:16 - 24 Nov 2017 04:07 #65968 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols

* Change FrskyX timing, from hexfet
Timing change fixes issue with telemetry when using LBT option.

(18.11.2017) Firmware DFU file only, you can get other components from official v5.0.0 release. For Devo 12e you can use Devo 10 filesystem.
www.deviationtx.com/downloads-new/category/398-deviation-5-0-0


Files deleted, see below...
Last edit: 24 Nov 2017 04:07 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
24 Nov 2017 04:10 - 08 Dec 2017 04:19 #66113 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols

* Fix S-FHSS protocol, from goebish

(24.11.2017) Firmware DFU file only, you can get other components from official v5.0.0 release. For Devo 12e you can use Devo 10 filesystem.
www.deviationtx.com/downloads-new/category/398-deviation-5-0-0


Files deleted, see below...
Last edit: 08 Dec 2017 04:19 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
08 Dec 2017 04:21 - 28 Dec 2017 09:10 #66401 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols

* Change CC2500 output power values, from vladislavy

Now the output power corresponds to the selected value, for all values.


(08.12.2017) Firmware DFU file only, you can get other components from official v5.0.0 release. For Devo 12e you can use Devo 10 filesystem.
www.deviationtx.com/downloads-new/category/398-deviation-5-0-0


Files deleted, see below...
Last edit: 28 Dec 2017 09:10 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
11 Dec 2017 08:47 #66437 by jpnews
Hello
On the latest firmware version (deviation-t8g-V5.0.0-2017-12-08). The firmware version does not appear in the Jumper T8SG radio or the version is not recognized by the radio.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 00:58 #66503 by joeclone
Replied by joeclone on topic Deviation v5.0.0 build with latest protocols
I tried the latest nightly 8dec2017, using devo10. I have a nrf24 on a13, a7105 on a14 and a cc2500 on b7. I'm running on a few models with dsmx, flysky and frsky. I find with this latest nightly I'm not able to bind with my dsmx/dsm2 models. I tried flashing the official 5.0.0 release and everything works again. Is this a bug or is there any changes to work with spektrum?

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 04:07 #66504 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
I don't know if there are any problems with Nightly Builds protocols, they are completely the same with my builds. Probably some new nightly builds features interfere with some protocols. I suspect it has place with DSM2/X protocols.

I recommend you to use v5.0.0 build from current topic, it has all new protocols and stable v5.0.0 official release core. I use it very long time and havn't any problems. You need to use Nightly Builds only if you need some new features.

If you have official 5.0.0 release installed, you can flash firmware file (dfu) only, filesystem is not changed.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 04:19 #66505 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols

jpnews wrote: Hello
On the latest firmware version (deviation-t8g-V5.0.0-2017-12-08). The firmware version does not appear in the Jumper T8SG radio or the version is not recognized by the radio.


Probably you use wrong build. From the factory T8SG has one of Nightly Builds firmware. Try to flash latest nightly build.
www.deviationtx.com/downloads-new/category/13-nightly-builds

If you wish to use "Deviation v5.0.0 build with latest protocols", you need to do clean install (with filesystem), since it use quite different filesystem.

I personally use "Deviation v5.0.0 build with latest protocols", since I don't need any new features of Nightly Builds.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 05:25 - 15 Dec 2017 05:30 #66506 by joeclone
Replied by joeclone on topic Deviation v5.0.0 build with latest protocols

vlad_vy wrote: I don't know if there are any problems with Nightly Builds protocols, they are completely the same with my builds. Probably some new nightly builds features interfere with some protocols. I suspect it has place with DSM2/X protocols.

I recommend you to use v5.0.0 build from current topic, it has all new protocols and stable v5.0.0 official release core. I use it very long time and havn't any problems. You need to use Nightly Builds only if you need some new features.

If you have official 5.0.0 release installed, you can flash firmware file (dfu) only, filesystem is not changed.


The reason I'm trying out this nightly is coz it supports frsky x protocol and unfortunately official 5.0.0 doesn't. I tried only dfu with the 5.0.0 filesystem but when I power on the tx screen is mixed up like the fonts arrangements dun match.
Last edit: 15 Dec 2017 05:30 by joeclone.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 05:40 - 15 Dec 2017 05:42 #66508 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
If you have nightly build installed, you need to do clean install since filesystem is different. Take filesystem from the official 5.0.0 release.
Last edit: 15 Dec 2017 05:42 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 06:42 #66509 by joeclone
Replied by joeclone on topic Deviation v5.0.0 build with latest protocols
yes I did, flashed nightly code then format quick erase drive and copy and paste filesystem from 5.0.0 zip and tx screen not displaying correct. Did the same for nightly filesystem and could see no problem in tx screen.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 06:51 #66512 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
I don't see any problems with current emulator code and filesystem from v5.0.0 build.

Attachments:

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 06:55 - 15 Dec 2017 12:57 #66513 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Try complete build "Deviation v5.0.0 build with latest protocols" for Devo 10.

File deleted...
Last edit: 15 Dec 2017 12:57 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 08:53 #66515 by joeclone
Replied by joeclone on topic Deviation v5.0.0 build with latest protocols
Thanks vlad, will try out later and report back.

Please Log in or Create an account to join the conversation.

More
15 Dec 2017 11:56 #66517 by joeclone
Replied by joeclone on topic Deviation v5.0.0 build with latest protocols
Ok just flashed this file and tested everything works again. Thumbs up for a good job vlad! This should be filed as 5.0.1 release. All of the stable release with all the new added protocols.

Please Log in or Create an account to join the conversation.

More
28 Dec 2017 09:09 - 03 Jan 2018 06:43 #66628 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols

* Fix 4ch_dr.ini template
* Update and synchronize "config.ini" files
* Fix vertical alignment for BDF fonts
* Fix mistypes

WARNING!!! There are some minor changes at filesystem. The "config.ini" file, "4ch_dr.ini" file (all transmitters) and "04b03.fon" file (128x64 GUI).

(28.12.2017)


Files deleted, see below...
Last edit: 03 Jan 2018 06:43 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
03 Jan 2018 06:47 - 24 Jan 2018 04:08 #66689 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols

* Disable support for devo7e, due to lack of memory
* Parse txid from the hardware.ini as u32

WARNING!!! Anyone who used hardware.ini "txid" larger then 0x7fffffff will need to rebind all the receivers.

(03.01.2018)


Files deleted, see below...
Last edit: 24 Jan 2018 04:08 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
09 Jan 2018 10:25 #66781 by jpnews
Hi Vlad vy
I updated the firmware of my Jumper T8SG radio with the latest version 03.01.2018
I found that I no longer have information on the switches (ex: SDW1 which is replaced by AUX4).
It's normal or it's a soft bug.

Please Log in or Create an account to join the conversation.

More
09 Jan 2018 10:43 - 09 Jan 2018 10:54 #66782 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
I havn't idea. Nothing changed about switches. What you see at Channel monitor screen?

What firmware do you use previously? v5.0.0 builds or Nightly builds?

Check your hardware.ini file:
;Only useful for transmitters with an after-market vibration motor
;enable-haptic=1
;
;switch_types: 3x4, 3x3, 3x2, 3x1, 2x8, 2x7, 2x6, 2x5, 2x4, 2x3, 2x2, 2x1, potx2, potx1
;May occur more than once if necessary.
;Add nostock if stock FMOD and HOLD switches have been removed.
  extra-switches = nostock
  extra-switches = 3x4
; extra-switches = 2x2
  extra-switches = potx2
;
;button_types: trim-all, trim-(left|right)-(up|down|both)
;May occur more than once if necessary.
;extra-buttons=
;
[modules]
; there is no need to enable the cyrf6936 module unless
; it is wired to an alternate port. It is Enabled automatically otherwise
; enable-cyrf6936 = B12
; has_pa-cyrf6936 = 1
  enable-a7105    = A13
  has_pa-a7105    = 1
  enable-cc2500   = A14
  has_pa-cc2500   = 1
  enable-nrf24l01 = A15
  has_pa-nrf24l01 = 1
; enable-multimod = A13
Last edit: 09 Jan 2018 10:54 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
09 Jan 2018 11:31 #66783 by jpnews
Before I used the firmware version deviation-t8sg-v5.0.0-4810939 of 18/12/2017 and I did not have this problem. All my switches are in AUX4 AUX3 - AUX2 - AUX1 etc ....

Please Log in or Create an account to join the conversation.

More
09 Jan 2018 11:38 #66784 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Probably it related to mixed filesystems, if you don't replaced Nightly Build filesystem to v5.0.0 filesystem.

If you like to use "v5.0.0 build with latest protocols", you need change filesystem. Otherwise you need flash latest Nightly build.

Please Log in or Create an account to join the conversation.

Time to create page: 0.170 seconds
Powered by Kunena Forum