Devo f12e fpv stops working after deviation

More
09 Jan 2017 19:03 #57758 by victzh
Replied by victzh on topic Devo f12e fpv stops working after deviation
Sure, I will, as soon as I'm home - in 5 hours or so.

Please Log in or Create an account to join the conversation.

More
09 Jan 2017 20:19 #57759 by Artus
If help a litte i am able to test also, i have 2 F12 , Hardware 1.2 A and B.
Installed CC2500 module in the B version and Deviation latest nightly.

DEVO10 4in1 V5.0 DEVO F12E 4in1 V5
Align TREX 100 (3) Hubsan Q4
Walkera QRW100S Walkera QRX 350 Pro (FPV)
Walkera QRX 350 PREMIUM
DIY 100 mm Micro QUAD - HGLRCF4F5PRO with INAV

Please Log in or Create an account to join the conversation.

More
09 Jan 2017 20:44 #57760 by victzh
Replied by victzh on topic Devo f12e fpv stops working after deviation
Artus, does current Deviation nightly work on your F12Es?

Please Log in or Create an account to join the conversation.

More
09 Jan 2017 22:16 - 09 Jan 2017 22:38 #57762 by Artus
I have build now a new test equiment.

F12E (CC2500) - FrksyX4RSB- Foxeer Video Transmitter.

After Modelsetup - Video Setup - its not possible to change Video enable - always jumping between AUX 6 and 7. and i am can not disable video.

But no freeze.

Video was set to Throttle with a former nightly.

Sorry - it was set now to AUX7 - and it will able and disable.



(Hope i can do a reset)

DEVO10 4in1 V5.0 DEVO F12E 4in1 V5
Align TREX 100 (3) Hubsan Q4
Walkera QRW100S Walkera QRX 350 Pro (FPV)
Walkera QRX 350 PREMIUM
DIY 100 mm Micro QUAD - HGLRCF4F5PRO with INAV
Last edit: 09 Jan 2017 22:38 by Artus.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 00:55 #57765 by Bonemyster
Replied by Bonemyster on topic Devo f12e fpv stops working after deviation
I tried that reference point and it was just like the reference point before this one. I could load up the fpv just fine but i could not load any models. When i hit load next to file it goes to a page that say "Press ENT to load". I then press ENT and nothing happens.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 01:08 #57766 by Bonemyster
Replied by Bonemyster on topic Devo f12e fpv stops working after deviation
Attached a photo of my friend devo f12e version, hope it helps, if needed i can also open up my f12e and take a pic of its version.
Attachments:

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 02:35 - 10 Jan 2017 02:39 #57769 by Artus
My f12E hardware is also marked with 2014.05.30.

I tried now to find out my problem - make a new devo.fs file - and now i can select how to enable video without problems. Seems AUX 6 und 7 was not at "neutral" bevor i start "video setup". video starts und stops now.

But the fist thing i have done is using an external antenna for my CC2500. I have disassembled the 12V output - cause i thinks i will never need - and use the hole for my external antenna.

I think the fpv reciever dont really like to have a transmitter in the near. I have a devo 10 with a fpv monitor - and if try to use more output power for TX the video is disturbed.
(But this is only my personal opinion)

DEVO10 4in1 V5.0 DEVO F12E 4in1 V5
Align TREX 100 (3) Hubsan Q4
Walkera QRW100S Walkera QRX 350 Pro (FPV)
Walkera QRX 350 PREMIUM
DIY 100 mm Micro QUAD - HGLRCF4F5PRO with INAV
Last edit: 10 Jan 2017 02:39 by Artus.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 04:16 #57772 by vlad_vy
Replied by vlad_vy on topic Devo f12e fpv stops working after deviation

Bonemyster wrote: I tried that reference point and it was just like the reference point before this one. I could load up the fpv just fine but i could not load any models. When i hit load next to file it goes to a page that say "Press ENT to load". I then press ENT and nothing happens.


It looks like video problem related to initialization sequence. I will try to build custom nightly build with "tw8816_init_bl1.3a.h" initialization sequence.

Reference point #4

File Attachment:

File Name: devoF12E-2...1-10.zip
File Size:136 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 04:18 #57773 by Bonemyster
Replied by Bonemyster on topic Devo f12e fpv stops working after deviation
Thats my friends devo f12e, and that is an old picture, he had me put an external antenna since then. I also have the fpv problem on my f12e that has not been modded with any modules. The problem i am having and others are having has nothing to do with an antenna being close to the fpv receiver, it about a bug in deviation.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 04:33 #57774 by Bonemyster
Replied by Bonemyster on topic Devo f12e fpv stops working after deviation
Reference point 4, fpv working, can now save models and load them. I havent tried flying anything with it since i will be installing a 4 in 1 later on and have my other devos for flying.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 05:18 #57775 by Artus
Sorry for my idea about the antenna - i am not an expert.
I am planning to use a 4 in 1 modul - cause i dont like the antennawood on this TX.

Vlady - i was not able to use the devo.fs in your zip file - i have copyied my "old". What can be the reason ?

Your devo.fs is (openend with notepad is in another format)

DEVO10 4in1 V5.0 DEVO F12E 4in1 V5
Align TREX 100 (3) Hubsan Q4
Walkera QRW100S Walkera QRX 350 Pro (FPV)
Walkera QRX 350 PREMIUM
DIY 100 mm Micro QUAD - HGLRCF4F5PRO with INAV

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 05:25 #57776 by victzh
Replied by victzh on topic Devo f12e fpv stops working after deviation
OK, it's really initialization. Using tw8816_init_bl1.3a.h works fine for my version of F12E. I did not use your build, Vlad, I modified trunk. Now we need to find 2 things: how to tell hardware versions (maybe PB already does this in the code, I did not look into it thoroughly yet.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 05:27 - 10 Jan 2017 05:28 #57777 by vlad_vy
Replied by vlad_vy on topic Devo f12e fpv stops working after deviation
Artus, what deviation version do you use? And about which zip file do you say? Reference point #4?
Last edit: 10 Jan 2017 05:28 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 05:34 - 10 Jan 2017 05:34 #57778 by vlad_vy
Replied by vlad_vy on topic Devo f12e fpv stops working after deviation
victzh, initialization sequence in "tw8816_init_1.5.h" skip some registers relative to "tw8816_init_bl1.3a.h". Can it be a reason?

...
0x89, 2,
0x9E, 0,
0x9F, 1,
0xA0, 0,
0xA1, 0,
0xA2, 0,
0xA3, 0x14,
0xA4, 2,
0xA5, 0x11,
0xA6, 0xE,
0xA7, 0x36,
0xA8, 0,
// 0xA9, 0xA0,
0xA9, 0x50,
0xAA, 0,
0xAB, 0x12,
0xAC, 0xF,
0xAD, 0,
// 0xAE, 8,
0xAE, 0,
0xB0, 0x48,
...
Last edit: 10 Jan 2017 05:34 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 05:55 #57779 by Artus
Yes - i use this one rev.4 You send a similar to another thread for me. Same result - your devo.fs is not working for me - i have to use one made with buildfs.

I have this .dfu file uploaded with Walkera DFUse - cause Devention uploader will not work - the send button is not active.


It is not urgent - i only want to know wheater i do something wrong.

DEVO10 4in1 V5.0 DEVO F12E 4in1 V5
Align TREX 100 (3) Hubsan Q4
Walkera QRW100S Walkera QRX 350 Pro (FPV)
Walkera QRX 350 PREMIUM
DIY 100 mm Micro QUAD - HGLRCF4F5PRO with INAV

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 06:02 #57780 by victzh
Replied by victzh on topic Devo f12e fpv stops working after deviation
Non default registers:
0x9F = 1, OSD Window Enable
0xA3 = 0x14, OSD Window H-Width (1 character per step) - means 20 characters
0xA4 = 2, OSD Window V-Height (1 scan-line per step) - 2pixels
0xA5 = 0x11, OSD Window Border Color Control and Border Color Width = 1
0xA6 = 0xE, OSD Window Look-up Table Selection Bit = 0, H-Border Width = 14 pix
0xA7 = 0x36, V-Border Width = 54 pix
0xA8, 0,
// 0xA9, 0xA0, Vertical and Horizontal Zoom = x3
0xA9 = 0x50, Vertical and Horizontal Zoom = x2
0xAA, 0,
0xAB, 0x12, Shadow color control = 1, Shadow width = 2
0xAC, 0xF, OSD Alpha blending amount = 15
0xAD, 0,

OSD means On-Screen Display.

There are some other differences between these sets, so you can't tell exactly which one is crucial for proper functioning. I can try to disable the absent registers to see whether they are the culprit. Maybe not today - it's 1AM here already.

What we can do is if nobody respond and say their Devo F12E works fine with current nightly we can replace the set of settings by working for us and wait for complaint :-)

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 06:19 - 10 Jan 2017 15:33 #57781 by vlad_vy
Replied by vlad_vy on topic Devo f12e fpv stops working after deviation
Summary of differences:

"tw8816_init_bl1.3a.h"
"tw8816_init_1.5.h"
7, 2,
7, 0x12,
9, 0xF0,
9, 0x20,
0x62, 0x76,
0x62, 0x94,
0x70, 0x20,
0x70, 0x60,
0xB3, 0xD2,
0xB3, 0x32,
0xB4, 0x2E,
0xB4, 0x24, //Based on results from tuning a recent Tx 2016-04-10
0xB8, 0x16,
0xB8, 0x14,
0xB9, 0x17,
0xB9, 0x20, //Based on results from tuning a recent Tx 2016-04-10
0xBA, 0xE0,
0xBA, 0xE2,
0xBE, 0xC0,
0xBE, 0x42,
0xFA, 0xE4,
0xFA, 0x92,
Last edit: 10 Jan 2017 15:33 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 07:24 #57782 by Artus
Another question: is there any reason why the telemetry monitor is not working (transmitter - menu) - if i start this - the TX is rebooting ..

DEVO10 4in1 V5.0 DEVO F12E 4in1 V5
Align TREX 100 (3) Hubsan Q4
Walkera QRW100S Walkera QRX 350 Pro (FPV)
Walkera QRX 350 PREMIUM
DIY 100 mm Micro QUAD - HGLRCF4F5PRO with INAV

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 10:12 - 10 Jan 2017 15:33 #57787 by vlad_vy
Replied by vlad_vy on topic Devo f12e fpv stops working after deviation
deleted
Last edit: 10 Jan 2017 15:33 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
10 Jan 2017 14:24 - 10 Jan 2017 14:32 #57789 by Bonemyster
Replied by Bonemyster on topic Devo f12e fpv stops working after deviation
Only reason I'm going to use a 4 in 1 is because in the past i have put 2 watt boosters in my friends devo f12e and got great range with the 3 in 1 module 1000plus meters. My friend told me he got about 2.1km in open space on the 3 in 1 with the 2 watt amplifier i put. amy test was not in open space and i got about 1000 meters. Of course I leave the booster inside the devo.
Last edit: 10 Jan 2017 14:32 by Bonemyster.

Please Log in or Create an account to join the conversation.

Time to create page: 0.058 seconds
Powered by Kunena Forum