How to upgrade Devo TX to Deviation Firmware

More
05 Mar 2013 08:45 #7379 by FDR

EVERNIN wrote: Hi, I am trying to upgrade my devo 8s to Deviation firmware, with no success, when while pressing EXT and power on tx, it appears program update on tx display, ok, but the dfuse tool on the pc does not recognize the tx. can you help?? Thank you. by the way please forgive my poor english, I am Mexican.


Which version of Dfuse are you using?

The v1.7 is the newest:
www.walkera.com/upload/upgrade/2013-2-26.rar

Please Log in or Create an account to join the conversation.

More
05 Apr 2013 03:25 #8544 by Helifan
Replied by Helifan on topic How to upgrade Devo TX to Deviation Firmware
Hi,
I am new to the deviation forum. I have a Devo 8s which I want to upgrade to deviation. I tried going to the Walkera website, but it seems it has changed and now I cannot find the Devention Difuse Upgrade Tools. I am running Mac OS X Mountain Lion.
Can you please help me?

Please Log in or Create an account to join the conversation.

More
05 Apr 2013 03:39 #8545 by Helifan
Replied by Helifan on topic How to upgrade Devo TX to Deviation Firmware
:P Found it!
Now I will try to proceed to the firmware update.
Does it only work on windows?

Please Log in or Create an account to join the conversation.

More
05 Apr 2013 03:56 #8546 by vlad_vy
Replied by vlad_vy on topic How to upgrade Devo TX to Deviation Firmware
Windows only.

Please Log in or Create an account to join the conversation.

More
22 Apr 2013 20:56 #9136 by bitchin86
Replied by bitchin86 on topic How to upgrade Devo TX to Deviation Firmware
video in second post by op says upgrade devo 7 software yet everyting i read says you cant run deviation on the devo 7? is there some way to make it work or what is the video about?

Please Log in or Create an account to join the conversation.

More
23 Apr 2013 04:06 #9138 by FDR
I guess he was talking about the 7E.
Deviation doesn't support the DEVO 7.

Please Log in or Create an account to join the conversation.

More
25 Apr 2013 22:06 #9212 by Tom Z
@FDR & bitchin86,

Were you talking about my post #3597 on page one?
If so I listed how to install the factory firmware for the Devo 6/8/7/10.
I removed the Devo 7 video so it doesn't confuse anyone. The deviation firmware is not for the Devo 7. I just listed how to restore the factory firmware for it.

Please Log in or Create an account to join the conversation.

More
01 May 2013 09:15 #9440 by Morten
Hi guyes.

I have a Devo 12, and i want to switch to Deviation 3.0 but i have some problems dooing that.
Ive tried on tree different computers with totally differen problems.

1 pc: Win 7 64 bit. Defuse (1.7 and 1.5 )installed but chrased every time i start it.

2 pc: Win xp 32 bit. Defuse (1.7 and 1.5 and 1.4) installed but when I start the transmitter in update mode it dosen't show up at the bottom of the defuse window. When i go to device mannager it shows there is no driver installed. I search the net for a driver but with no luck.

3 pc: Win 7 64 bit. Defuse 1.7 and 1.5 installed but chrased every time i start it. Installed Defuse 1.4 and suddently it dosent chrash yeah!! - I start the transmitter in update mode (trn switch and power button) it shows up at the bottom of the defuse window Yes!! But it dosent work when i try upgrading, and i get a error message.. Damn... Then i discover it dosent show up in the Available dfu devices at the top left corner of the defuse window. Im starting to get desperate now :woohoo: , what do i have to do? Please help me witch of the 3 pc should i use and what have i missed since i cant get it to work?

Thanks :)

Please Log in or Create an account to join the conversation.

More
01 May 2013 10:11 #9442 by vlad_vy
Replied by vlad_vy on topic How to upgrade Devo TX to Deviation Firmware
With Win Xp 32 bit I havn't any problems. But you can find driver at: C:\Program Files\devention Upgrade Tools\Driver\

Please Log in or Create an account to join the conversation.

More
01 May 2013 11:21 - 01 May 2013 11:22 #9445 by RandMental
Replied by RandMental on topic How to upgrade Devo TX to Deviation Firmware
There was sort of consensus that not working has something to do with the USB status on the PC. Personally I have never had any issues on WIN7, 64bit, but then I use it on my "clean" PC, which is not used for any development or having USB devices other than a USB flash drive.

Try disconnecting and even de-installing all the USB devices and drivers, reboot and start the DfuSe software. Hopefully that will work.
Last edit: 01 May 2013 11:22 by RandMental.

Please Log in or Create an account to join the conversation.

More
02 May 2013 11:08 #9477 by Morten
Thanks guyes!!

It turned out there was no drivers on my Xp pc, so i copied them from the win 7 pc an now i can flash the files on the Devo 12... Yes!!
I flashed both the .dfu file, formatted the drive, copied the files in the file system folder. Rebooted the Transmitter but the only thing on the screen is one icon with at helicopter and i can't select it. What did i do wrong? Right now i hav a non working transmitter and the wether is great for flying here in Denmark.


Attachments:

Please Log in or Create an account to join the conversation.

More
02 May 2013 11:42 #9478 by vlad_vy
Replied by vlad_vy on topic How to upgrade Devo TX to Deviation Firmware
You need also flash library file devo12-lib.dfu (located in filesystem archive), at Library tab of Defuse.

Please Log in or Create an account to join the conversation.

More
02 May 2013 13:20 #9479 by Morten
Thanks a lot Vlad now it works perfektly!!

Cant wait until it support my much bigger screen...

Im a happy man now!!

Please Log in or Create an account to join the conversation.

More
02 May 2013 18:39 #9485 by RoJAck
Thanks everyone!!! Another very satisfied Devo 10 customer here. Flying Walkera and Blade/E-Flite just fine so far.

Really nice job on the firmware, UI's, and instructions.

Please Log in or Create an account to join the conversation.

More
04 May 2013 01:06 #9520 by clearprop88
Replied by clearprop88 on topic How to upgrade Devo TX to Deviation Firmware
I used the 0.8B DFuse SW to load in my Deviation V3.0.
The reason I used it is because I used it before, and it works.
Is there any advantage to using the v1.7 of the DFuse SW?

The Deviation v3.0 seems to be working fine in my Devo 6 with the older version of DFuse.

Please Log in or Create an account to join the conversation.

  • rbe2012
  • rbe2012's Avatar
  • Offline
  • So much to do, so little time...
More
04 May 2013 06:53 #9524 by rbe2012
Replied by rbe2012 on topic How to upgrade Devo TX to Deviation Firmware
The newer versions support other tx models like the F7.

Please Log in or Create an account to join the conversation.

More
04 May 2013 14:56 - 04 May 2013 14:57 #9543 by clearprop88
Replied by clearprop88 on topic How to upgrade Devo TX to Deviation Firmware
Will it do any harm if I continue to use the 0.8B DFuse tool?
I will only be using it on my Devo 6, and 8.
Last edit: 04 May 2013 14:57 by clearprop88. Reason: add

Please Log in or Create an account to join the conversation.

  • rbe2012
  • rbe2012's Avatar
  • Offline
  • So much to do, so little time...
More
04 May 2013 16:34 #9546 by rbe2012
Replied by rbe2012 on topic How to upgrade Devo TX to Deviation Firmware
As far as I have understood: no, you can go on with the old version. They all just put a firmware image to the microprocessor. If it works once, it will work forever.

Please Log in or Create an account to join the conversation.

More
04 May 2013 19:38 #9557 by clearprop88
Replied by clearprop88 on topic How to upgrade Devo TX to Deviation Firmware
Thanks. That's what I was hopeing to hear.

Please Log in or Create an account to join the conversation.

More
09 May 2013 04:50 #9725 by vanwadiver
Replied by vanwadiver on topic How to upgrade Devo TX to Deviation Firmware
I seem to have dug myself into an interesting hole...

I received a brand-new, fresh from china, Devo 8S and proceeded to upgrade it to the Deviation 3.0 software. The upgrade process seemed to run fine, and I followed all instructions in the documentation as well as the video at the head of this post, but my Tx will only display a blank screen no matter what I do.

As far as I can tell, the correct number of beeps seem to be present at the right times: Power on, Power off, etc. but other than the beeps, I can't tell if the software is actually functional or not.

I've repeatedly tried installing Deviation v3.0 as well as v2.1.1, and reverting the software back to v0.9A from Walkera. All to no avail. The only time I am able to see anything besides a blank screen is when holding down EXT and powering on, where I am able to see the Program Update screen, but that's it. Nothing else... nada...

Does anyone have any ideas on what may be wrong, or what else I might try to get the screen to show up?

Thanks for your help...

Please Log in or Create an account to join the conversation.

Time to create page: 0.101 seconds
Powered by Kunena Forum