Deviation v5.0.0 build with latest protocols

More
04 Oct 2016 11:28 - 05 Oct 2016 17:55 #54583 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
I can't build "v5.0.0 + new protocols" for Devo7e, main programm doesn't fit to RAM (about 20 bytes). I can only build for Devo7e the nightly build with modified DSM2/X protocol.

Devo7e nightly build (22.09.2016) + DSM2/X protocol, DFU and "protocol" folder only, all other can be found at nightly builds:

Files deleted, see below
Last edit: 05 Oct 2016 17:55 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
05 Oct 2016 17:59 - 07 Oct 2016 16:43 #54635 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Added ASSAN protocol. Also, changed DSM2/X protocol. I hope that this DSM2/X protocol version can fix all known problems - e.g. 6ch mode doesn't work with Orange satellite, and so on. Firmware DFU file only, you can get other components from official v5.0.0 release.
www.deviationtx.com/downloads-new/category/398-deviation-5-0-0

Also, for Devo7e nightly build with changed DSM2/X protocol. DFU and "protocol" folder only, you can get other components from official nightly builds.
www.deviationtx.com/downloads-new/category/549-2016-10-05

Files deleted, see below
Last edit: 07 Oct 2016 16:43 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
06 Oct 2016 16:00 #54657 by Wene001
Replied by Wene001 on topic Deviation v5.0.0 build with latest protocols
Thanks for your hard work vlad...
hope to see this in the nightlies soon. i need it in combination with frskyx

Please Log in or Create an account to join the conversation.

More
06 Oct 2016 16:57 #54663 by joeblack
Replied by joeblack on topic Deviation v5.0.0 build with latest protocols
Also wanna thank you for your hard work on developing Deviation further.
CU joerg

Please Log in or Create an account to join the conversation.

More
07 Oct 2016 04:52 - 10 Oct 2016 06:15 #54690 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Initial implementation DSM2/X protocol telemetry "Flight Log" filtering. I hope that you will not see anymore sporadiс wrong values at "Flight Log", only valid values. It's need testing as I can overlook some special cases, but at any case it's comзletely safe, at most you can get "frozen" Flight Log and Rx voltage telemetry, other sensors will work.

P.S. I can't fit "Flight Log" filtering to devo7e build, so it cutt out from code for Devo7e. Sorry...

Files deleted, see below
Last edit: 10 Oct 2016 06:15 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
07 Oct 2016 16:30 - 07 Oct 2016 16:31 #54693 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Now I can build "v5.0.0 with latest protocols" for ALL transmitters known at v5.0.0
Last edit: 07 Oct 2016 16:31 by vlad_vy.

Please Log in or Create an account to join the conversation.

  • BirdBarber
  • BirdBarber's Avatar
  • Offline
  • Hummingbird Assassin
More
07 Oct 2016 21:34 - 07 Oct 2016 22:36 #54702 by BirdBarber
Replied by BirdBarber on topic Deviation v5.0.0 build with latest protocols
A parody of the US elections:
vlad_vy - "Making Deviation Great Again"

Thanks Vlad, I love the old interface.
Last edit: 07 Oct 2016 22:36 by BirdBarber.

Please Log in or Create an account to join the conversation.

  • BirdBarber
  • BirdBarber's Avatar
  • Offline
  • Hummingbird Assassin
More
08 Oct 2016 23:38 - 08 Oct 2016 23:54 #54738 by BirdBarber
Replied by BirdBarber on topic Deviation v5.0.0 build with latest protocols
Just a FYI since you are under the hood - comments bug unfixed in all releases

I thought you were supposed to be able to keep comments in the model.ini files now, but all releases, yours and others, seem to delete them again when you make any change to the model in the transmitter.

This post said that it was fixed: www.deviationtx.com/forum/6-general-disc...odel-ini-files#42012

I tested this on D10 and 8S with V5.0.0, nightlies and your builds. All are deleting comments in the model.ini files.

If you ever get bored and want something to do...... hopefully the fix is out there and just didn't get merged into the current code.

I use comments in model.ini files to document channel layout and switch functions for models I release to other people. What would be really great is if the comments could be displayed on the transmitter screen especially now that quads have so many functions.
Last edit: 08 Oct 2016 23:54 by BirdBarber.

Please Log in or Create an account to join the conversation.

More
09 Oct 2016 15:06 #54758 by mwm
Is this build available as a github branch somewhere - preferably in the main repo? I'd love to see another automated build based on this. A lot of people run the nightly builds just to get new protocols. This was fine last year when the release was years old and the nightly was fairly stable, but that's no longer the case.

This is why one of the changes I wanted when I proposed forking deviation was to add an intermediate build between release and nightly: basically release + new protocols that were documented + bug fixes (loosely defined as not requiring a documentation change).

Do not ask me questions via PM. Ask in the forums, where I'll answer if I can.

My remotely piloted vehicle ("drone") is a yacht.

Please Log in or Create an account to join the conversation.

More
10 Oct 2016 06:17 - 11 Oct 2016 17:12 #54782 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Fix FrskyX dropout issue ( #43 )
* Fix incorrect length value in telemetry crc validation.
* Change telemtry packet processing to accept only packets with expected length (17 bytes).

hexfet

Firmware DFU file only, you can get other components from official v5.0.0 release.

Files deleted, see below
Last edit: 11 Oct 2016 17:12 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
10 Oct 2016 17:31 - 10 Oct 2016 21:06 #54796 by Thomas.Heiss
Replied by Thomas.Heiss on topic Deviation v5.0.0 build with latest protocols

Thomas.Heiss wrote:

Thomas.Heiss wrote: First firmware test today with zip/dfu version dated 09/28/2016. So one day / one version behind last final 09/29/2016 version
- Devo10
- AR6210
- TM1000

Telemetry monitor (and main telemetry voltage field) was frozen at 12.1V.
All telemetry monitor fields constantly black/inverted (including main screen voltage).
When I landed and had the transmitter in near of the TM1000 the telemetry did not come back anymore as release 5.0.0 + fcd0669 did before.
....
TX transmit signal was OK (no deadlock) - controlling the EPO glider was no problem over the whole flight.
....


I)
Another ground test in near distance with build version 09/28/2016 AR6210+TM1000 in same room immediately got me a frozen telemetry screen.
....Other tests at 100uw showed, like Vlad describes, that telemetry returned once back in distance.
2nd test flight showed again the same behavior (loss of telemetry in-flight).

II) New test with Devo10 build version 02 Oct 2016 08:55:
Same behavior as build 09/28/2016.

Re-producable / repeated telemetry losses in-flight (freeze). Transmit works fine (no deadlock).
It's always just a quick telemetry connection.

So somehow in my test setup telemetry RX code creates a hangup in sporadic situations, and is always re-producable in -flight.
First 100uw ground tests were in parallel successful however, see below.

I also encountered a COMPLETE RX/telemetry freeze, just like I did once with 200QX on an older Indigo DSM test build.
Plugging in a new flight pack did not reset telemetry monitor.
I had to either turn OFF the transmitter OR switch to another model memory slot.



III) New in-flight firmware test - 4 lipos (about 15-40 minutes per flight) - with Vlad's test build zip/dfu version dated 10/07/2016 with
- telemetry frozen fix "CYRF_06_RX_CFG, 0x48": www.deviationtx.com/forum/protocol-devel...rrors?start=20#54584
- new mentioned 7CH re-write DSMx protocol code
- including FlightLog filtering code from #54690 www.deviationtx.com/forum/builds/6407-de.../54562?quote=1#54690

with
- Devo10
- Spektrum AR6210 (6CH setting)
- Spektrum TM1000 (works fine - not corrupt)
- 100mw output power
- EPO glider (explicitly tried to fly higher + more far away - as far as I could see the 2,2m wing glider)

with
- 0 Holds
- <10 FrameLosses: checked 4 times (4 lipos) and it showed ~8F max., so far below 20F, quite good!


Telemetry monitor in this build is again rocking stable so far for me - just like release V5.0.0 + V4.01-nightly-build-fcd0669.
Checked the monitor multiple times "live" during flight, checked monitor FlightLog values after landing on each flight of the four.
Not freezed / fields black/inverted any time!!

TX transmit code rocking stable as in every Deviation version (no deadlocks, no holds, no >40F) before. Always full steering control at any time.

I currently have no alarm for "telemetry out of range" active during flight (e.g >40F), only H>0 warning.
Probably I would get noticed on (shorter) sporadic "telemetry (range) notifications" H=255?

Thomas.Heiss wrote:

vlad_vy wrote: I havn't problems with telemetry (Devo8+ AR6210 + TM1000), 100uw test, with distance up to many Frame losses and several Holds. V1 =7,33V, V2=6,3V or 11,2V with different batteries, GPS show all info. After telemetry fields become black/inverted, all restored with shorter distance.

P.S. I done several range tests, with many Frame Losses and 8 Holds, about 30 min of uninterrupted testing. Telemetry work fine, I can't get it frozen.


My 100uw first ground test on build 02 Oct 2016 08:55 (only did one) was successful, like Vlad described, too.
Out of range -> telemetry monitor black/inverted fields.
Back in range -> monitor fields back to normal + displaying new FlightLog numbers.
Typical test-case which always worked for 5.0.0 + fcd0669 before.

In-flight I lost again telemetry monitor link to TM1000 and it did not come back anymore when I landed and had the glider next to the transmitter.
Comparing builds 09/28 and 10/02 I would say that telemetry lost (out-of-range) was earlier with 09/28??
10/02 telemetry was fine for a while, I manually checked the screen if the fields were black/inverted that soon.

I will have to go back and re-test with release 5.0.0, which always worked - like V4.0.1-nightly-build fcd0669 (BitBucket) - once I fix this glider fuselage (little bit of trouble with bad sight / cloudy / dark as of today).
....
I will try to re-test without bat field on main screen as well was with 5.0.0.
With build 10/02/2016 my test was with configured Bat telemetry alarm on #4-6 jumping slots, so I should have noticed.
With build 09/28/2016 my test was with configured Bat telemetry alarm on #1-3 non-jumping slots.


Further 100µw/300µw/1mw ground tests on Vlad's test build zip/dfu version dated 10/07/2016 with fixes/protocol enhancements are on my TODO list.

For the above III) in-flight test Bat telemetry alarm on #4-6 jumping slots +RxV (#1-3 non-jumping slots) was activated.
Bat telemetry on main screen (3s) was activated too for in-flight test - works great.
I have NOT noticed swapping of the telemetry fields to black/inverted at any time (when I looked up here and then).
So this works for me on 3s.


However I would love to have a previous build zip without latest FlightLog filtering code enhancement - so I can maybe intensively re-test FlightLog telemetry out of range / sporadic number jumping cases and write down all numbers I see on telemetry monitor.

....Like I did my videos before on Indigos test build 36cce5c once in the "DSM telemetry support" thread.

I somehow missed to download the previous build zip without FlightLog filtering before :)
Update: Thanks Vlad for old build zip upload.

Will try to start with this build 10/07/2016 and it's added (basic) FlightLog filtering code if time allows next 4-6 weeks.
Well, why even bother testing ground range on 100µw-1mw output power when it works just that great in-flight on 100mw :) :)


Q: Is it better to activate FlightLog logging and use the CSV transform tool instead of only manually writing down shown FlightLog numbers from telemetry monitor?

Will probably ask some further "understanding code" questions on current Vlad's implementation on our "DSMx/protocol errors" thread after re-checking "DSM telemetry support" thread...there was one comment about it by Vlad in the latter thread some time ago...

Thanks to Vlad for your support!

Thomas
Last edit: 10 Oct 2016 21:06 by Thomas.Heiss.

Please Log in or Create an account to join the conversation.

More
10 Oct 2016 19:16 - 11 Oct 2016 17:13 #54799 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Thomas,

Devo10 build without Flight Log filtering (05.10.2016):

File deleted
Last edit: 11 Oct 2016 17:13 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
11 Oct 2016 17:18 - 12 Oct 2016 19:01 #54825 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
It looks like I found simpler and more reliable way for DSM2/X protocol telemetry "Flight Log" filtering. Moreover, it fit to Devo7e.

Thomas, can you test this build (11.10.2016) too?

FrskyX protocol
* Fix infinite loop issue for certain values of tx id.
hexfet

Firmware DFU file only, you can get other components from official v5.0.0 release.

Files deleted, see below
Last edit: 12 Oct 2016 19:01 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
11 Oct 2016 20:07 - 11 Oct 2016 20:08 #54832 by MacGyverek
Replied by MacGyverek on topic Deviation v5.0.0 build with latest protocols
I made a upgrade from 4.01 to this 5.0 build (with DSM protocol fixes). I found a problem in GUI - Devo8S. On main screen in Boxes (like Timer, Throttle) I see a value refresh like flickering. I don't know why probiem is.
Last edit: 11 Oct 2016 20:08 by MacGyverek.

Please Log in or Create an account to join the conversation.

More
12 Oct 2016 09:56 - 12 Oct 2016 10:25 #54850 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
If it's about white background in the boxes on the home screen flashes bands of dark color each time digits change value, it was fixed after v5.0.0 release.
Last edit: 12 Oct 2016 10:25 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
12 Oct 2016 10:11 #54851 by MacGyverek
Replied by MacGyverek on topic Deviation v5.0.0 build with latest protocols
Yes, its this problem.

Please Log in or Create an account to join the conversation.

More
12 Oct 2016 10:26 - 12 Oct 2016 19:01 #54852 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
Can you try this one build and report if it's better:

File deleted, see below
Last edit: 12 Oct 2016 19:01 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
12 Oct 2016 12:03 #54853 by bianchifan
Replied by bianchifan on topic Deviation v5.0.0 build with latest protocols

vlad_vy wrote: Moreover, it fit to Devo7e..

Just even checked, it seems to run on my nonstandard ultimate 7e, only some protocol mismatches..muchas gracias.

Is itpossible to get an "ultimate version"?
I.E. language support, added switches, added pots..

Please Log in or Create an account to join the conversation.

More
12 Oct 2016 13:27 - 12 Oct 2016 19:04 #54854 by vlad_vy
Replied by vlad_vy on topic Deviation v5.0.0 build with latest protocols
OK, see below, "devo7e-256" added to other builds.
Last edit: 12 Oct 2016 19:04 by vlad_vy.

Please Log in or Create an account to join the conversation.

More
12 Oct 2016 17:44 #54858 by MacGyverek
Replied by MacGyverek on topic Deviation v5.0.0 build with latest protocols
Thank you vlady_vy. Now DEVO8S working without box flickering.

Please Log in or Create an account to join the conversation.

Time to create page: 0.115 seconds
Powered by Kunena Forum