expressLRS

More
16 Dec 2022 19:07 #78140 by estojicmm
Replied by estojicmm on topic expressLRS
Hi,

Despite many attempts I couldn't make ELRS TX module connected to DEVO 7E to bind with the receiver. I have:

- Happymodel ES24TX module
- SPI ELRS receiver built in BetaFPV 1-2S 12A FC
- I am using the latest "deviation-devo7e-v5.0.0-987234e" nightly build on Devo 7E.
- I've tried both ELRS 2.0 and ELRS 2.5.1 on TX side,
- on RX side it is ELRS2.0 I assume, since FC is flashed with Betaflight 4.3.0, official release
- I tried both UART inverted and not inverted option (don't know if it is important any more)
- On Devo7E CRSF protocol is chosen.
- Binding phrase is set on TX and it is also entered to SPI receiver using Betaflight CLI command (set expresslrs_uid =...)
- TX signal input is connected to tip point on DEVO 7E 3.5mm interface. It is also checked with oscilloscope and signal is present. LEDs in TX module are turned on, showing it is powered.
- The same TX module connected to Jumper T-Lite works fine with the same receiver

Do you guys have any idea what I am doing wrong?

Thanks.

Please Log in or Create an account to join the conversation.

More
16 Dec 2022 21:44 - 16 Dec 2022 21:45 #78141 by hexfet
Replied by hexfet on topic expressLRS

Slawyn41 wrote: I DUNNO HOW TO ENABLE EXTERNAL RF AND I DIDNT FIND ANY INFO ON IT ONLINE

Deviation doesn't have control of the expansion bay power pin. You should see a little less than battery voltage on the JR bay power pins whenever the radio is powered on.

Did the radio come with a standard build of deviation, or did Radiomaster make some changes? What version (including radio model) did you install?
Last edit: 16 Dec 2022 21:45 by hexfet.

Please Log in or Create an account to join the conversation.

More
16 Dec 2022 22:13 - 16 Dec 2022 22:14 #78142 by hexfet
Replied by hexfet on topic expressLRS

estojicmm wrote: Hi,

- I tried both UART inverted and not inverted option (don't know if it is important any more)
- The same TX module connected to Jumper T-Lite works fine with the same receiver

Do you guys have any idea what I am doing wrong?

Thanks.

Most of the configuration looks fine to me. The UART setting needs to be non-inverted for ELRS 2. With ELRS 3 or later and a TX with an ESP32 processor the inverted setting doesn't matter .

Are you using the model match feature? If so try turning it off. Since the 7e doesn't have enough memory to support CRSF configuration it also can't tell the TX at startup time which model match ID to use. I don't know if the TX powers up with the model ID it was previously using or not.
Last edit: 16 Dec 2022 22:14 by hexfet.

Please Log in or Create an account to join the conversation.

More
16 Dec 2022 22:22 #78143 by estojicmm
Replied by estojicmm on topic expressLRS
Thanks Hexfet for the quick reply. I am not using model match feature.

It is important information that Uart should be non-inverted on ELRS2.0. I am stuck with 2.0 because I have only SPI receivers. I have one regular receiver on the way, so I'll try with it as well once it arrives.

Please Log in or Create an account to join the conversation.

More
16 Dec 2022 22:45 #78144 by hexfet
Replied by hexfet on topic expressLRS
Might want to check the timing on the tip signal matches the bit rate you have selected for CRSF. And it looks strong with little noise? I'd stick with 400K bit-rate setting on CRSF until it's working. And 2.25M requires ELRS 3.

Please Log in or Create an account to join the conversation.

More
16 Dec 2022 23:24 - 16 Dec 2022 23:26 #78145 by gittaimi
Replied by gittaimi on topic expressLRS
Hi
I have 7e 256 and R9M and R9M lite modules( elrs2.1). Can I use those? If so, which nightly should I use?
Thx
Last edit: 16 Dec 2022 23:26 by gittaimi.

Please Log in or Create an account to join the conversation.

More
17 Dec 2022 08:28 #78146 by estojicmm
Replied by estojicmm on topic expressLRS

hexfet wrote: Might want to check the timing on the tip signal matches the bit rate you have selected for CRSF. And it looks strong with little noise? I'd stick with 400K bit-rate setting on CRSF until it's working. And 2.25M requires ELRS 3.


The signal is strong with little noise. Signal periods in 400K seems to be in exact inverse proportion to 2.25M (approximately 5 times longer).

Please Log in or Create an account to join the conversation.

More
17 Dec 2022 10:52 #78147 by estojicmm
Replied by estojicmm on topic expressLRS
Seems that my Devo7E doesn't communicate with HM ES24TX module. When this TX module is just plugged in powered Jumper T-lite I see substantial RF power emission on my DIY RF power meter, even without any receiver bound. That is not happening if TX module is connected with Devo7E.

Please Log in or Create an account to join the conversation.

More
17 Dec 2022 15:02 #78148 by hexfet
Replied by hexfet on topic expressLRS

gittaimi wrote: Hi
I have 7e 256 and R9M and R9M lite modules( elrs2.1). Can I use those? If so, which nightly should I use?
Thx

Deviation CRSF will support ELRS configuration on the 7e-256. I don't know about putting ELRS on that hardware.

The current nightly build is here .

Please Log in or Create an account to join the conversation.

More
17 Dec 2022 15:46 #78149 by hexfet
Replied by hexfet on topic expressLRS

estojicmm wrote: Seems that my Devo7E doesn't communicate with HM ES24TX module. When this TX module is just plugged in powered Jumper T-lite I see substantial RF power emission on my DIY RF power meter, even without any receiver bound. That is not happening if TX module is connected with Devo7E.

If you have a logic analyzer or FTDI you could check the validity of the CRSF data. I tested a build in my t8sg with telemetry and config disabled which is as close as I can get to a 7e. The TX and RX connected fine as long as model match was off so I think the 7e CRSF output should be fine.

If you enable the auto-wifi on the TX does it go into wifi mode after the timeout? That would indicate it's not receiving a CRSF signal.

Please Log in or Create an account to join the conversation.

More
17 Dec 2022 16:11 #78150 by estojicmm
Replied by estojicmm on topic expressLRS
That is the firmware I am using.
I don't have logic analyzer.
TX goes into wifi mode after the timeout.

Some people reported successful connection with Devo7E, so I am probably doing something wrong, but failing to find out what is the problem. I checked many times that everything is connected correctly. For now I am giving up.

Thank you very much for your development and your support.

Please Log in or Create an account to join the conversation.

More
21 Jan 2023 21:50 - 21 Jan 2023 21:56 #78197 by hexfet
Replied by hexfet on topic expressLRS
New nightly build is available with some changes in CRSF.

* New telemetry sensor decoding for CRSF_VARIO, BARO_ALT (with vario), TX_ID, and RX_ID.
* Fix for CRSF menu COMMAND options that may change dialog type during operation
* Extend max dialog prompt length from 19 to 39 characters

The dialog fixes may not affect ELRS. Noticed the problem with TBS "Set Failsafe" command.

Users manual is updated. Since I can't update the official links I've used Github Pages to make a page with links to the latest Deviation build and manuals.
Last edit: 21 Jan 2023 21:56 by hexfet.

Please Log in or Create an account to join the conversation.

More
26 Jan 2023 06:40 - 26 Jan 2023 06:43 #78202 by rc manic
Replied by rc manic on topic expressLRS
Deviation uploader 0.9.0 will not unpack the newest T8SG-V2 zip file. Downloaded several times with same result.
Still unpacks all previous firmware builds. Also unpacks newest T8SG-V2-Plus and 7e-256 files, just not T8SG-V2
Anyone else having same issue?
Last edit: 26 Jan 2023 06:43 by rc manic.

Please Log in or Create an account to join the conversation.

More
26 Jan 2023 08:25 #78203 by belrik
Replied by belrik on topic expressLRS

rc manic wrote: Deviation uploader 0.9.0 will not unpack the newest T8SG-V2 zip file. Downloaded several times with same result.
Still unpacks all previous firmware builds. Also unpacks newest T8SG-V2-Plus and 7e-256 files, just not T8SG-V2
Anyone else having same issue?


Are you using the DFU file inside to upgrade? That should work for firmware update.

Please Log in or Create an account to join the conversation.

More
26 Jan 2023 18:23 #78204 by rc manic
Replied by rc manic on topic expressLRS
The Deviation uploader should automatically extract the DFU from zip file. However, I also extracted and tried to load the DFU , did not work.

Please Log in or Create an account to join the conversation.

More
27 Jan 2023 01:09 #78205 by hexfet
Replied by hexfet on topic expressLRS
The dfu in the t8sg_v2 archive is zero length. Sorry about that. My build box has been crashing and must've interrupted that build.

I've rebuilt and re-uploaded. New download link is here

Please Log in or Create an account to join the conversation.

More
27 Jan 2023 01:23 #78206 by rc manic
Replied by rc manic on topic expressLRS
No issue at all. Thanks Hexfet, your work has allowed the Deviation program to live on.

Please Log in or Create an account to join the conversation.

More
27 Jan 2023 16:32 #78208 by hexfet
Replied by hexfet on topic expressLRS
You're welcome, and thanks!

Please Log in or Create an account to join the conversation.

Time to create page: 0.096 seconds
Powered by Kunena Forum