Ultimate 7e-256k builds

More
10 Jun 2016 23:32 #50371 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds
ver. 6a7c620 , I get different result as Fernandez, it sill stuck at "RUD" almost same problem ......... :(

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 06:17 #50382 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
What do you mean stuck at rudder?

From my side I can confirm my 4 switches all work in any combination of setting, which was not the case before.
I did not do more testing than that.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 06:42 #50383 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds

Fernandez wrote: What do you mean stuck at rudder?

From my side I can confirm my 4 switches all work in any combination of setting, which was not the case before.
I did not do more testing than that.


Please take a look at my post #50247 , there is a vedio, almost same situation but a bit more worse than that.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 09:27 #50388 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
I rechecked but see no issue. Did you verify with the outputs of switches? I think it might just be the display and detect in change?

In do not know the threshold hysteresis when stick change is being detected, but what could happen is you have some noise or spikes on voltages? Being then detected on rudder move?

Check output of a switch channel I expect is working fine now.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 18:33 #50409 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
Hi guys, I'm still looking at the original switch mod. We seem to be getting closer. Could you try out these 2 builds and let me know how they work? Thanks!

deviation-devo7e-256-v5.0.0-98f8b8d

deviation-devo7e-256-v5.0.0-b2cd419

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 19:57 - 11 Jun 2016 19:57 #50417 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
I can't understand why fernandez and dc59 are having different results with the same mods?
Last edit: 11 Jun 2016 19:57 by HappyHarry.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 20:16 #50421 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
I can't either. What Fernandez suggested is possible, given the birds nest of wires and the different power regulators we have. But I can't really test for that. Or possibly code changes in the nightly vs release 5.0.0 might have some effect on the mixer display. One other possibility is that the same buggy build was uploaded twice. I didn't actually commit the code changes thus the 2 test files were both showing 6a7c620. It's possible that there was a mix up. I committed the code this time and merged into both the release 5.0.0 branch and the nightly branch, thus 2 files to test. Hopefully they both work for both of them. *fingers crossed*

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 20:21 #50422 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Hi the first file posted works fine on the conventional switch setup, now loading the second one.

I really think that analog pots being detected need some hysteresis, so +- 10% stick move to be detected.
I guess he pick up noise and I am pretty confident that when assigning switches to channels and he check the output they do operate normal.

Maybe stupid question, when uploading new firmware, when do you need to upload the new directories, is it needed ?

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 20:27 #50423 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
The second firmware posted also works fine with my conventional 2x2 2x3 switches.

Did you change the hysteresis, on the analog pots for stick detection, I have to move them some bit out of the center.

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 20:39 #50424 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
with the u7e we don't really need to update the filesystem anymore (unless there are changes in hardware.ini or tx.ini) as the protocols are no longer seperate modules but built into the binary. are your pots still like that after calibration?

Please Log in or Create an account to join the conversation.

More
11 Jun 2016 20:49 #50426 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
I have really no problems, switches and Tx works fine. Not been flying, but just o the bench.

The sticks have too move far out, so pretty sure can't be false detected by noise.
Which of the two firmwares should I use?

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 00:00 - 12 Jun 2016 00:50 #50440 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds
Both test build work fine, if I don't touch any stick or select switch/source by R+/L- button ! :(

if I select source(Src) by stick , it always change back to "RUD" whatever you input and if I select Src by R+/L- button there is no THR/ELE/AIL item only RUD and switch.

I have checked channel monitor , there is no jittering on CH4.

Maybe it's really a menu/button system problem! because I also found a bug when I press only one times L+/R+/UP+/DN- , it will move 2 steps just like I pressed it twice.

But all these issues don't happen on May 25th build, I can use stick/button to select all inputs/switches .
Last edit: 12 Jun 2016 00:50 by dc59.

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 00:49 #50443 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds
I take som vedio about test,
May 25th test build works fine



New test build b2cd419 got troubles.
When I try to take test video , it seems became worse .

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 07:04 #50452 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Hmm very very weird, totally different behavior than mine........ All switches sticks are now detected fine.

I use now deviation-devo7e-256-v5.0.0-98f8b8d (the first of the two posted, as it have the more recent protocols frsky x included.
I will fly it today to see if it is stable.

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 07:58 #50455 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
dc59 what are the extra switches on the shoulder of your tx?

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 11:03 #50465 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds
I just wired A0 and A2 switch to left and right shoulder button , it works for some toy quad as taking picture or vedio button.
Nothing special. :P

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 12:27 #50468 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Just been test flying 8 packs with the U7E and 2x2 2x3,

I had no issues what so ever, all switches work and system is reliable, I get the telemetry information and alarms for low battery pack. .I have been flying my sig Wonder plane (3 switches used here) and QAV210 Betaflight (all 4 switches in use here) both on Frsky D8 protocol.

I can say for me the U7E works as good as before the mod!.

now can continue upgrading add the new switches and pots and voice alerts. But I'll await when all is sorted, as mentione would love to have 4 switches each side, as I have the space for it.

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 14:29 #50474 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds

dc59 wrote: I just wired A0 and A2 switch to left and right shoulder button , it works for some toy quad as taking picture or vedio button.
Nothing special. :P


i was interested in what function you would use momentary switches for, and for pictures and starting/stopping video makes perfect sense :)

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 18:07 #50480 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
@dc59, thanks for the videos! I'll dig deeper to see if i can find something that explains the problem. If it's not too much trouble, I was wondering if you can check your switch diodes? If the diode is leaky it might cause problems. The way the button/switch reading was changed between the 25th may version and the current test builds. In order to support both types of mods in the current test builds, the switches for the original mod are read in both directions, diodes that are good would prevent one of the 2 directions. It might be possible that a faulty diode is causing some form of ghosting in the matrix. But I must say it's odd that it causes RUD to show up.

Also in channel monitor when you are looking for jitters, did you try toggling the switches?

Last thing is to try using the buttons again to change inputs, but with all 3-way switches in the 1 position (centre). Basically the 1 position for the switches means they are not connected. Thus hopefully taking all switch reads out of the equation.

@fernandez, thanks for testing too! Glad to know things are good on your end. I've not forgotten about your switch configuration. I have a theoretical solution, just need some time to put it into code. Thanks for the patience!

If anyone else with a U7E has the original 2x3way mod, please test out the above 2 linked builds. I'd like to make sure that it does work and is not a fluk. Thanks for the help!

Please Log in or Create an account to join the conversation.

More
12 Jun 2016 18:30 - 12 Jun 2016 18:31 #50481 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Thanks Silpstream, at least for now can be flying with it reliable. I am a bit depending on my Tx, as it is my main unit right now. But as soon as there is a solution I'll happy to wire all switches and pot's.

A universal solution defined in .ini file, would be ideal as that way users can choose it own preferred switches setup.

For pushbutton, some of them in the back of TX maybe within easy reach, but this is sill future wish.... I was thinking to get voice command on poll, f.i,. get pack voltage, lowest cell, flying speed, current, flying time, capacity used etc just what you program under it, get that on demand. Or maybe be able to circulate true two or three telemetry values?

Indeed for cameras, smoke generators or other non directly related to flying stuff.
Last edit: 12 Jun 2016 18:31 by Fernandez.

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum