Ultimate 7e-256k builds

More
07 Jun 2016 16:10 #50104 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
ok i just updated to ed27f5f and then on to the latest build c07562a and i can find no issues with the switches bud

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 16:14 #50107 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
I've been prey to sub-par components before... :lol:

Thanks for testing things HH!

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 16:39 - 07 Jun 2016 16:41 #50110 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
yeah me too, with pb finding that nothing was wrong but continuity errors on the last chip i soldered to my original 7e (i only did continuity checks on the first 2 chips i replaced, i guess as my new 7e was coming and that i was predisposed to the old one being broken i never bothered doing any real fault finding when the 3rd chip didn't work either :/ ) it shows that the first batch of mcu's i bought from ebay were faulty, and that will explain why they weren't filling the properties boxes properly in the stlink software! serves me right for buying the cheapest mcu's i could find on ebay lol

though once i get this board back i'll have 3 ult7e's and the total number of known ult7e's will hit 20 :D
Last edit: 07 Jun 2016 16:41 by HappyHarry.

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 20:26 - 07 Jun 2016 20:29 #50129 by compman2
Replied by compman2 on topic Ultimate 7e-256k builds
I am the preson Cereal_Killer did the proc swap for. Thanks a bunch

My issue with the chinese diode's wasn't that they didn't work but they were so poorly marked that I installed them backwards. I got out another diode that I had laying around and ran a continuity test to see which way the current would pass based on the "clear" markings, and used this to test the diodes and get them oriented the right way. Once correctly oriented they work fine. However it is worth a couple of extra bucks to not have to go through the trouble shooting process. Clearly marked "quality" diodes would have saved me some time and frustration.

computer nerd, hobby collector, proud father
Last edit: 07 Jun 2016 20:29 by compman2.

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 21:18 - 07 Jun 2016 21:19 #50140 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Measured the wires, they are ok as expected.

My report above is actually not 100% correct.
Both the 2 way switches work fine in any position.
Both the 3 way switches work fine in any of the 3 positions, but they can only can be changed with both of the two way position switches on. When one or both 2way switches are set to off the 3way switch value stays in its last position, what ever the new position of the 3 way switch is set.

Flipping the 2 ways then the 3 way position changes.
I see it also in other models.
Before these models worked perfectly fine.

could it also be something like safety is activated in some faulty way ?
Attachments:
Last edit: 07 Jun 2016 21:19 by Fernandez.

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 21:38 #50145 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
have you checked this behaviour with a blank new model.ini?

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 21:39 #50146 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
No I did not implement extra switches pots yet unconnected, just the 2x2 and 2x3 as always used.
I use the old model files as used before the Ultimate build.
Also use the same ini file as before, mentioning 2x3

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 21:51 - 07 Jun 2016 21:54 #50148 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
i don't currently have a main board for my 7e that's set up with 2x3way and 2x2way's, and it will be a while till i get it back so i can't check any more than i have tonight sorry, but tomorrow i'll add 2x3ways to my backup ult7e and i'll test it then. so wait until tomorrow bud

one thing you may try is adding
extra-switches=2x2

underneath the extra-switches = 3x2 so it looks like

extra-switches=3x2
extra-switches=2x2

and seeing if that helps, as you need to declare all the extra switches with the new ult7e firmware
Last edit: 07 Jun 2016 21:54 by HappyHarry.

Please Log in or Create an account to join the conversation.

More
07 Jun 2016 22:01 #50149 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Hmmm added the line 2x2 switches, but doesn't change.

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 05:43 #50159 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
Fernandez, I might have found a problem, but I need some help confirming it.

1) Are you using the original Devo7E 3-way switch mod? This one: http://static.rcgroups.net/forums/attachments/5/6/3/4/2/8/a8100083-188-201507_Devo7E_Extra-2x3-posSwitchMod.jpg .

2) If you are, can you download deviation-devo7e-256-v5.0.0-20may2016 and test it. Tell me if the problem is there and if it is exactly the same as what you reported in post#50140.

We'll get this sorted. Thanks!

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 07:07 #50161 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
1) Yes correct the original mod is in place.

2) Thanks very much, I hope to try it tonight and report. (But anyway I plan to add all the full new switches config, but possibly to get this sorted might help others)

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 17:57 #50192 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
I loaded the 5.0.0.0 of 20may, but the problem stay exactly same, no difference

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 18:53 #50194 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
I just made some changes. It is uploaded as deviation-devo7e-256-v5.0.0-20160609 in the test builds section under [silpstream].

@Fernandez, could you test it. You should have "extra-switches=3x2" only in your ini file.

@Cereal_killer, could you do me a favour and test also with your switch setup?

@Anyone else that has time, do test to see if it works properly cause I could only test with 4x3-way, 2x2-way configuration. If someone has a U7E with only the stock switches (HOLD, FMOD) or some other configuration other than mine, then testing would be appreciated.

I'd like to put this to rest before working on the new switch code that will allow for more flexible configuration.

Thanks a lot everyone!

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 19:59 #50201 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Before I test it just to double check there is no mistake:


The download is folder named: deviation-devo7e-256-v5.0.0-20160609
But dfu file inside that folder is named: deviation-devo7e-256-v5.0.0-6a7c620

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 20:05 #50202 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
Yes. That's right.

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 20:37 #50204 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
There is a change with this firmware;

The 2x3 switches both do not work at all now in any position and whatever position of the 2ways.
The both 2 way still operate fine in both conditions.

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 20:45 #50206 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
Could you post up your ini file? Thanks!

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 20:56 #50207 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
btw do we not confuse; 3x2 or 2x3

attached my ini, downloaded from tx, always been used for the " non ultimate" .
Attachments:

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 21:02 #50208 by silpstream
Replied by silpstream on topic Ultimate 7e-256k builds
We use "extra-switches=3x2" so your ini is correct.

My bad. Could you try "deviation-devo7e-256-v5.0.0-20160609b.zip"? It will give you the same "6a7c620" dfu cause I haven't committed the changes. Thanks again!

Please Log in or Create an account to join the conversation.

More
08 Jun 2016 21:34 #50210 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Tested it but it is back to same situation 2way both work always, the 3ways only work when both 2 ways are both in the up position.

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum