Ultimate 7e-256k builds

More
15 Jul 2016 20:36 - 15 Jul 2016 20:36 #51729 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
new builds are up guys, but looking at things there hasn't been any actual code changes (the only commits were protocol descriptions) since silpstream did the last builds (thanks again for volunteering bud :D ) so there is no point in updating your tx's this time round, with that in mind i've not updated the op
Last edit: 15 Jul 2016 20:36 by HappyHarry.

Please Log in or Create an account to join the conversation.

More
28 Aug 2016 03:27 - 28 Aug 2016 04:27 #53180 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds
Edit 2: Well I dont know whos build it is (65ec105) but I have all switches and pots functioning and I have FrSky-X!!! So freaking cool! I just came in from flying (albiet for 2 minutes) my mini-tri with my mini transmitter (without buddy-boxing threw my X9E or D10 mind you)! This community is so awesome!

Gentlemen,
What would it take to get HexFet's FrSky-X build into the U7E? I've finally gotten around to throwing a CC2500 into my U7E and tho it's working great for D series FrSky receivers I'd really like to actually start using my 7E again to fly my mini tricopter and it's an X4R (and cant be swapped to a D4R because of the serial port configuration it's FC is running).


Haven't updated in a while so I'm gonna go ahead and load the most recent build tonight, the 7E will still get use (it's delegated to my wife's plane mostly) but I'd really be happy if it was atleast in the works... How many other people do we need to ask for the same thing before it gets bumped up in priority?


Edit: I see Hexfet has a 256k 7E build of his FrSky-X build but it doesnt include the extra switchs / pots. Maybe I'll request he include that code instead of you guys include his code. Either way I'll be a happy camper!


File Attachment:

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/
Last edit: 28 Aug 2016 04:27 by Cereal_Killer.

Please Log in or Create an account to join the conversation.

More
28 Aug 2016 03:38 - 28 Aug 2016 04:28 #53181 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds
Edit: This problem is solved, for some reason adding the " extra-switches = nostock" line to my existing HW.ini file didnt work, deleting it and replacing the file did work though so I'm g2g, just need me some FrSky-X.

BTW what happened to the protocol directory the stock 7E requires? Has that been gone since the beginning?


Hey guys, sorry for 2 posts in a row.

So I've just updated and I lost the use of all 4 extra 3-way switches (A - D) and what's strange is in the input monitor Hold and Fmode are both showing again tho NONE show ANY movement, neither of the stock switches (which are obviously gone) nor SWA - SWD. The Pots however do function fine.


I cant revert as computer problems over the past month mean no saved copy of whatever build I had on there last when it all worked.

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/
Last edit: 28 Aug 2016 04:28 by Cereal_Killer.

Please Log in or Create an account to join the conversation.

More
28 Aug 2016 06:36 #53183 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
glad to see your sorted bud, and yeah as the u7e has more space the protocols are compiled into the firmware like most other devo tx's, so there's no longer any need to build the protocols as modules and store them on the flash, hence no protocols folder :)

Please Log in or Create an account to join the conversation.

More
28 Aug 2016 09:41 - 28 Aug 2016 09:42 #53185 by Fernandez
Replied by Fernandez on topic Ultimate 7e-256k builds
Hi guys I also still enjoy very much my ultimate and switches, I am currently running this firmware from Goebish;
www.deviationtx.com/forum/protocol-devel...-it4?start=280#52530
(It also has AFHDS 2A test build)

Next step would be to add the voice module is it included in the Utimate 7e, any news here ? wa salo some discussion connecting it to another pin, to save the ppm port.
Last edit: 28 Aug 2016 09:42 by Fernandez.

Please Log in or Create an account to join the conversation.

More
29 Aug 2016 18:15 #53247 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds
Hi guys, running 65ec105

I had a MAJOR problem today that my tx got stuck in USB mode (at the field when I was flying) and when I finally got home and plugged it into my computer my computer popped up and said it HAD to be formatted before it could be used...


I had been flying for about 27 minutes (3 batteries, but tx left powred at model battery swaps) all perfect, I had been datalogging and was just about to try a long range flight so I wanted to quickly test my failsafe. I held the model, throttled up so it thought it was flying and switched the Tx off [the models FS functioned perfect] so I went to switch the u7e back on and that's when the USB icon was on screen and nothing I did changed that. I even unplugged the battery for about 2 hours and tried again and it was still stuck in that state and then when I got home my computer said what I put above.


Luckily I had another tx with me and luckily it happened when it did. I'm positive it had something to do with datalogging as I had been changing settings there immediately before that flying session. unfortunately all logged data was lost in the format.

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/

Please Log in or Create an account to join the conversation.

More
29 Aug 2016 19:15 #53248 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
that doesn't sound good! I wonder if you ran out of space on the flash, or if a read/write error corrupted the file table or something different altogether? I'll see if I can trigger the same error and I'll post back

Please Log in or Create an account to join the conversation.

More
29 Aug 2016 19:27 #53249 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds
I dont think I ran out of space, not sure how fast it should fill up but less than 10 min before I still had 16k bytes left and all I was logging only 4 parameters:

Enable with SW C1
rate 1Sec
Select none
Timer 1 on
TelemRSSI on
TelemVAmp on


This is on FrSky-X protocol

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/

Please Log in or Create an account to join the conversation.

More
02 Sep 2016 09:30 - 02 Sep 2016 09:31 #53404 by bianchifan
Replied by bianchifan on topic Ultimate 7e-256k builds

HappyHarry wrote: as always if you find any bugs post them on the bugtracker here >>

Deviation Bug Tracker


Where ?

Attachments:
Last edit: 02 Sep 2016 09:31 by bianchifan.

Please Log in or Create an account to join the conversation.

More
02 Sep 2016 10:29 #53406 by FDR
Replied by FDR on topic Ultimate 7e-256k builds
The bug tracker is out of order at the moment.
...actually for the last two months... :(

Please Log in or Create an account to join the conversation.

More
02 Sep 2016 12:33 #53408 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds
Update on my issue above: it happened AGAIN!

Still a large number of bytes left for logging, logging same parameters too. I did notice both times my battery was under 5v however not low enough to sound / give me a warning (above 4.8 where I have my alarm set) so I know it's not simply dying.


I have not reformatted yet as I'm hoping for a way to recover the log file. If it was an actual SD card I'm confident I could access and save (and repair if necessary) the file but being as how my computer refuses to do anything other than format I'm not sure what steps to take.
Can anyone help me with that?

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/

Please Log in or Create an account to join the conversation.

More
02 Sep 2016 22:02 #53426 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
this doesn't sound good, I've not managed to reproduce it but I'll try again. does it only happen when you power off the tx while logging data?

for revovering the data on the drive i'd try using linux and something like photorec/testdisk and see if that can repair/read the partition.

Please Log in or Create an account to join the conversation.

More
03 Sep 2016 13:46 #53447 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds

HappyHarry wrote: does it only happen when you power off the tx while logging data?.


Yes


Silpstream could you do me a newer build (an update to 65ec105)?

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/

Please Log in or Create an account to join the conversation.

More
03 Sep 2016 17:43 #53450 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
I think this is a file writing issue, the tx is writing to the flash when you turn off the tx and this corrupts the fat table, one of the devs will have to look at the logging code and add in a way to tell it to stop writing when the shutdown signal is sent.

as for a new build there has been no real additions to the codebase to warrant a new build bud (only a channel expansion to an little used protocol), hence why I've not updated my builds

Please Log in or Create an account to join the conversation.

More
07 Sep 2016 21:27 #53607 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
there were some new protocols added to the nightly so i've updated the build, the link is in the first post 8)

this build includes silpstreams most recent fixes for the switchmods code which are currently waiting in the pull request queue on top of tonights nightly. additions to this nightly build include the protocol for the eachine E010, the protocol for the FQ777-124 with the ssv7241 rf chip, as well as the addition to the hubsan protocol to support the h301.

enjoy :)

Please Log in or Create an account to join the conversation.

More
08 Sep 2016 00:24 - 08 Sep 2016 00:27 #53613 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds

HappyHarry wrote: there were some new protocols added to the nightly so i've updated the build, the link is in the first post 8)

this build includes silpstreams most recent fixes for the switchmods code which are currently waiting in the pull request queue on top of tonights nightly. additions to this nightly build include the protocol for the eachine E010, the protocol for the FQ777-124 with the ssv7241 rf chip, as well as the addition to the hubsan protocol to support the h301.

enjoy :)


:woohoo: Thanks HH!
But I can't find 'protocol' directory in zip file. :(
Last edit: 08 Sep 2016 00:27 by dc59.

Please Log in or Create an account to join the conversation.

More
08 Sep 2016 01:41 #53617 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
no probs bud :) as the u7e has more space on the mcu it doesn't require the protocols to be built as modules and stored on the flash, so there is no need for the protocols folder :)

Please Log in or Create an account to join the conversation.

More
08 Sep 2016 02:15 #53619 by dc59
Replied by dc59 on topic Ultimate 7e-256k builds

HappyHarry wrote: no probs bud :) as the u7e has more space on the mcu it doesn't require the protocols to be built as modules and stored on the flash, so there is no need for the protocols folder :)


No wonder!
Thanks for explanation. :lol:

Please Log in or Create an account to join the conversation.

More
17 Sep 2016 14:12 - 18 Sep 2016 14:55 #53961 by Cereal_Killer
Replied by Cereal_Killer on topic Ultimate 7e-256k builds
Hi again gentlemen.

In my 7e builds I can't hold rt/Lt or up/dn to have it roll threw menus / selections continously, I have to press the button one time for each step I take. I thought this was strange but I couldn't remember for sure. I used my 10 yesterday and set up a new model and had lots of menus to navigate and it rolls threw every selection just fine.

Is the lack of scrolling by design or a bug?

Taranis X9E | DEVO 10 | Devo U7E | Taranis Q7

What I do in real life: rivergoequestrian.com/
Last edit: 18 Sep 2016 14:55 by Cereal_Killer.

Please Log in or Create an account to join the conversation.

More
17 Sep 2016 16:24 #53968 by HappyHarry
Replied by HappyHarry on topic Ultimate 7e-256k builds
it works ok for me bud, long press scrolls through the options on all screens i tried. is anyone else having this issue?

Please Log in or Create an account to join the conversation.

Time to create page: 0.103 seconds
Powered by Kunena Forum